BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Port 8441-8444 is blocked on my ISP

#1

Can i use different port to sending data from my raspi to the cloud? because my isp blocked these port, and when i asked them to open it, they refuse to open it

0 Likes

#2

We don’t use these ports anymore. Right now we support 443 port for app side and 80 port for hardware side. 8441 is still used for SSL hardware connection.

0 Likes

#3

so, am i need to change some line at blynk library in my raspi to use another port? because on my isp, every non usual port got blocked

0 Likes

#4

Yes (well in your client code, not in the library itself), use port 8080

What script language are you using for the Blynk client on your RPi?

0 Likes

#5

i use JavaScript to programming on my pi, and from what i learn, the port that i will use written on blynk library, not in the code itself

0 Likes

#6

How about updating the library? That might help :wink:

-edit

Depending if you use SSL or not for you Pi connection to the cloud ofcourse.

Btrw ISP’s usually don’t block ports. It has to do with some laws, but it could vary per country.

0 Likes

#7

Not for NodeJS

EDIT, sorry, I guess it depends on if you use Local Server (like I do) or Cloud… and as stated, if you update your NodeJS library, it should account for the new port.

0 Likes

#8

I’ve already updating the library but it still used 8441 port, emm i use ssl for my pi because my university network need ssl to login to the network. maybe i should change the default port on the blynk conf?

0 Likes

#9

How can i update the port from 8441 to 9443 or any other port that is working. I am working on NodeJs language on client side.

var Bblynk = require(’/usr/local/lib/node_modules/blynk-library’);
var AUTH = ‘ea81f239a646e4850992032363ed’;
var blynk = new Bblynk.Blynk(AUTH);
var v1 = new blynk.VirtualPin(1);
var v2 = new blynk.VirtualPin(2);

v1.on(‘write’, function(param) {
console.log(‘V1:’, param[0]);
});

v2.on(‘write’, function(para) {
console.log(‘V2:’, para[0]);
//v2.write(new Date().getSeconds());
});

Where should i make changes in the code? and also what is the permanent solution.

0 Likes

#10
new Blynk.Blynk(AUTH, options= {addr:"xxx.xxx.xxx.xxx", port:9443});

Also you can use regular 443.

1 Like

#11

@Manraj_Singh You already have your own topic with same question. As already mentioned before…there is no need to post repeating questions in other’s older topics.

1 Like

closed #12
0 Likes