Pin assignments disappearing

Since the last release, each time I open my project, it has deleted all of the pin assignments. I set them up again, and when I exit, it loses them again.

I don’t think it has anything to do with my code, since everything works perfectly once I recreate a he assignments, and the code has been unchanged for months.

iOS 9.0.2 on 2 devices: iPhone 5s, iPhone 6

Sorry for that

We have a couple of reports about that already. Trying to fix it, but still no luck with reproducing.
Which hardware are you using?
Do you use local server or Blynk Cloud?
Any particular set of actions that causes it?

Thanks for any information and sorry for the inconvenience.

Just experienced the same issue.
I use Blynk Cloud.
iPhone 6
My board is a Mega2560 V3, but it seems as if the error is in the app.
My project has been running for some days with no errors. But over night all my pin assignments were gone. The pins and buttons were not assigned at all.
Yesterday I tried for the first time to switch between using my iPad or my iPhone as controller. Apparently it worked OK, but this morning…

I am using Arduino Pro Mini with an ESP 8266 as a modem.

I am using Blynk Cloud.

We figured out the reason of defect and will resolve it in the next release.
Solution is below:

  1. Just delete your Blynk application from your Apple device (do not start Dashboard before this - in case if you have already started Dashbord after loosing your settings, you’ll need to setup all virtual pins again after step 2).
  2. Install the most recent version from AppStore again.
    Thanks for you patience and sorry for the inconvenience.

If I delete the Blynk application will I need a new Auth Token or will it be retained when I reinstall the latest version from the app store?


You will only need a new auth token if you delete your dashboard. Re-installing the App shouldn’t have an effect on that.

1 Like

Ok, so I should stop the dashboard first, delete the app from my phone, reinstall the app on my phone and all should be well?


Yeap, exactly =). 20 chars limit

Thank you both very much


Thank you for your replies, that worked.