Packet too big?

Hello,

Do you know what means : “Packet too big: 51200” in the serial log?
After it I’ve heartbeat timeout, and attempts to reconnect without success…

It probably means a packet (i.e. data) was too big (i.e. opposite of too small).

Search that error here to see if there is any similar references to whatever it is you are doing… then if you still have questions, please supply actual details of whatever it is you are doing :wink:

https://community.blynk.cc/search?q=Packet%20too%20big

Hello,
I mean the serial output of the IDE where I check the stability of the connection of a device under test.
It only send a blynk.write each 10sec, and log events as heartbeat timeout… and this message I had never seen before “packet too big”.

I check your link…

Well, start with enabling debug serial output, then post serial monitor output and your sketch here… then perhaps someone will then be able to assist.

I see that the last data is corrupted=>
[36537655] <[06|0E]G[00|00]
[36537692] >[0E]G[00|C8|00]
[36537693] Packet too big: 51200
[36537694] Connecting to 109.8:8442
[36562750] Heartbeat timeout: 36562750, 36527692, 36537655
[36562752] Disconnected

The sketch is very basic=>

//V1.1: to test stability connection & debug (23648/1357) -> reconnect OK après ~60sec perte réseau
//V1.2: blynk.config -> reconnect ok après  23228/1366  -> reconnect OK après ~270sec perte réseau 
#define BLYNK_PRINT Serial    // Comment this out to disable prints and save flash space
#define BLYNK_DEBUG           // Optional, this enables lots of prints
#define BLYNK_NO_BUILTIN        // Disable built-in analog & digital pin operations to spare space
#define BLYNK_NO_FLOAT          // Disable float operations to spare flash space
#define BLYNK_NO_INFO           // Skip device info to spare flash space
#include <BlynkSimpleUIPEthernet.h>   // ENC28J60 ethernet BLYNK library
/////////////////////////////////////////////////////////////////////////////////
char auth[] = "";
char Flag_Init_Boot='0';
byte arduino_mac[] = {};    
IPAddress arduino_ip ( );
IPAddress dns_ip     (  );
IPAddress gateway_ip ( );
IPAddress subnet_mask();

void setup() {
  Serial.begin(9600);                           // start serial for output  
  Ethernet.begin(arduino_mac, arduino_ip, dns_ip, gateway_ip, subnet_mask );
  Blynk.config(auth, "IP", Port);  
}

void loop(){  
while (Blynk.connected()==false) {Blynk.disconnect(); Blynk.connect();}  
Blynk.run(); 

  if (Flag_Init_Boot=='0'){                                         
  Blynk.email(F("R8"),F("WD"));
  Flag_Init_Boot='1';   
  }
}  
  • local or cloud server (based on the ip address it is a non blynk server from belgium)?
  • do you use ssl?
  • what blynk lib version are you using?
  • maybe you have a “hacked” uipethernet lib to reduce sketch footprint?

Hello,

Yes it’s a local server with last release. I use also last android lib version.
I don’t use SSL, or I think so because I don’t really understood how to use it. So I let this config in the properties file as default.

BUT you are right, I have a hacked uipethernet to reduce the sketch!

i have a feeling that this causes the problem…

do you have any solid reason why to struggle with uno + ethernet module, and not to use esp8266 or at least arduino mega, instead?

I can’t change the hardware, its’ nano+enjc60. I don’t want use wifi under an hive, and everything is already on poduction.
Anyway the problem is not blocking because in case of such issue, the arduino reboots with watchdog, and reconnects immediatly. It runs several days whitout rebooting.
I just like to understand, and if possible, improve the system…

For next project, sure I’ll try esp!