Notification limit period appears to not be working

I may not understand the function under notifications but I have set the Limit Period to 5 minutes with 1 event counter. My hardware is set to send the notification once a minute. I am receiving the notifications once a minute instead of once every 5 minutes as I would expect. Am I understanding the Limit Period correctly?

Hey there,

Limit Period- limits the number of notifications to just one notification for a specified time period. Timer starts when first Event happened and notification sent.
:sparkle: Example: if you set 1 hour as a limit, end-users will only get one notification within 1 hour after the first event was recorded. No matter how many events are generated by hardware (or API calls) during one hour after that, no notifications will be sent.

Event Counter - notification will be sent only after a number of events was recorded. Counter starts when first event happened. After counter value was met, counter resets to zero.
:sparkle: Example: if the counter is set to 50 and device sends 100 events, the user would only get 1 notification (every 51st event will trigger the notification).

You can also use Limit period and Event counter together.
:sparkle: Example: set Limit Period to 1 hour and Event Counter to 5.
When first event is recorded, the Limit Period timer starts and Event Counter startsDevice sends 100 eventsWhen 6th event is logged, a notification is sent because counter value is metNo more notifications are sent because 1h limit is active

So with the period set to 5 minutes with 1 notification should I only get one notification at most every 5 minutes?


@jstobaugh your understanding is correct. We’ll check.

We checked. All is ok. Maybe you mean timeline events and not notifications?

After seeing the timeline events I see that it does show every 1 minute entry and that was confusing me. Would it be possible to have an option to just show when a notification was sent from Blynk?

At the moment - no. However, I agree, it’s confusing. We’ll think over it.