Nodemcu restarts

I am using Nodemcu board and flashed Nodemcu firmware. Here I was trying to use it with google assistant using IFTTT whenever I give command from google assistant to operate led on nodemcu the nodemcu restarts.

can you elaborate what do you mean by nodemcu firmware?

Nodemcu code in arduino library examples. I flashed it on nodemcu board.

Probably a bug in your sketch, perhaps if you post it in a forum formatted manner then someone might take a look at it for you.

 #define BLYNK_PRINT Serial
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

char auth[] = "YourAuthToken";


char ssid[] = "YourNetworkName";
char pass[] = "YourPassword";

void setup()
{
  
  Serial.begin(9600);

  Blynk.begin(auth, ssid, pass);

}

void loop()
{
  Blynk.run();
}

This is the code used.

Now format it.

I have edited the post which contains the NodeMCU code.

@gauravkrpyo the correct “format” is back-ticks fore and aft of your code, as shown here (and you can look back at your post to see the corrections I made).

Blynk - FTFC

I got that.

Well, there doesn’t appear to be anything wrong with your code, as it is very basic. So either poor WiFi signal, WiFi interference, bad power, bad board, etc.

Everything is checked and the above said things are fine. It works fine when I toggle the led from Blynk app.

Something is clearly not fine… and it doesn’t appear something we can troubleshoot here.

Try loading other examples in and see how they work.

https://examples.blynk.cc/?board=NodeMCU&shield=ESP8266%20WiFi&example=GettingStarted%2FPushData

Then everything IS working… I still suspect you have issues on your end that is causing the disconnection. Low current and bad WiFi are top culprits.

How are you powering the NodeMCU and can you test connection with Hotspot on your phone?

First I was powering it from PC then I powered it from 5V adapter. Results were same.
I didn’t tried it on hotspot of my phone. But I checked it on 3 of my WiFi.

Let me try to use my phone as hotspot.

This issue is solved. I was using the D8 pin on Nodemcu but in actual it is GPIO15 of the ESP12E so on the IFTTT part I have to write D15 to use the D8 pin of the Nodemcu.

2 Likes