NodeMCU keeps connecting

I just got a new NodeMCU and when I try to connect it with the tutorial code it displays this message:
“⸮⸮=s⸮⸮[262] Connecting to Web2”
And nothing happens afterwards…
Rate is at 9600
What am I doing wrong?

My crystal ball states you have a bug in your code at… Line 46…:wink:

Seriously… Could you provide more details like your code (properly formatted) rather than “nothing happens”?

2 Likes

Ok, so I’m using the tutorial code:

#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "hiding for this post";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "Web2";
char pass[] = "88881111";

void setup()
{
  // Debug console
  Serial.begin(9600);

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 8442);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8442);
}

void loop()
{
  Blynk.run();
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!
}

Did you add the Blynk Libraries according the docs?

1 Like

Yeap

it seems that can’t connect to your wifi.

check esp power source, check signal strength, reset router, etc

2 Likes

Its all working, tried all my bands, I think it’s on the arduino side since there’s the strange characters before the message

no, the strange caracters are normal at the beginning of serial output with esp82 boards.

do you have more esp boards? maybe you could try another one?

1 Like

No :C I have an UNO, this is my first time with Wifi

hm, than make sure the ssid and pass are correct.
did you tried restarting the router?
maybe there is mac filter enabled?

1 Like

Turns out that restarted the modem worked… I feel dumb… Thanks guys :v:

Good! Enjoy Blynk!

And change that serial rate to 115200 :wink: