BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

NodeMcu-Invalid auth token

just slip server between auth and ssid.

When the geo fixed is rolled out you can just change xxx.xxx.xxx.xxx to blynk-cloud.com

Seriell Monitor:
Connecting to 139.59.206.133

thats all.
App is telling: “Device is offline”

Screenshot of Serial Monitor and confirm ping is 139.59.206.133 for sketch and app.

SSID and pwd correct?

Still struggling, take a new token from app and enter in the sketch.

SERIAL MONITOR:
I_€à=Sÿþ[258] Connecting to 139.59.206.133

PING:
Ping wird ausgeführt für blynk-cloud.com [139.59.206.133] mit 32 Bytes Daten:
Antwort von 139.59.206.133: Bytes=32 Zeit=24ms TTL=55
Antwort von 139.59.206.133: Bytes=32 Zeit=27ms TTL=55
Antwort von 139.59.206.133: Bytes=32 Zeit=23ms TTL=55
Antwort von 139.59.206.133: Bytes=32 Zeit=29ms TTL=55

Ping-Statistik für 139.59.206.133:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 23ms, Maximum = 29ms, Mittelwert = 25ms

SSID/PASSWORD:
Yes correct, NodeMCU is connected successful to my router (looked in router)

BLYNK APP:
Connection set to Custom
IP: 139.59.206.133
Port: 8443

Have you tried a new token since you made all the changes?

no, but i did now.

Still the same

Auth Key = 18a5b6b352af4ddc915a4c2d1ec8d91d

What library version are you using?

What does the following show you?

telnet 139.59.206.133 8443

It should connect you for perhaps a minute or so before dropping the connection.

Paste your formatted sketch.

connection closed by remote host

directly

that’s the correct response because with telnet you don’t provide a token, just means routing to the Blynk server is not blocked on port 8443.

Formatted sketch?

standard at first:

-#define BLYNK_PRINT Serial // Comment this out to disable prints and save space
-#include <ESP8266WiFi.h>
-#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = “​18a5b6b352af4ddc915a4c2d1ec8d91d”;
char server[] = “139.59.206.133”;

// Your WiFi credentials.
// Set password to “” for open networks.
char ssid[] = “ssidname”;
char pass[] = “password”;

void setup()
{
Serial.begin(9600);
Blynk.begin(auth, server, ssid, pass);
}

void loop()
{
Blynk.run();
Serial.println(“Hello”);
}


had to add a - to the includes because of formatting in this editor

Sketch formatting: [README] Welcome to Blynk Community!

change 9600 to 115200

Move Serial.println(“Hello”); to last line of setup() NOT loop().

noting changed

Does the following in a web browser show you your project details?

https://139.59.206.133/​18a5b6b352af4ddc915a4c2d1ec8d91d/project

Invalid token.

It worked for me.

You have either the wrong ip or wrong token in your project. Check them again until you get the correct info from the url in a browser.

1 Like

the correct url to ping is:
blynk-cloud.com ?

yes

ok, reinstalled Blynk app on my android, create a new projekt.

ping blynk-cloud.com

reply 139.59.206.133

open:
https://139.59.206.133/e8509f285b374b8cb08f3165b93c96c2/project

get:
{“id”:1,“name”:“nodemcu1”,“createdAt”:1483895034615,“updatedAt”:1483895117523,“widgets”:[{“type”:“BUTTON”,“id”:1,“x”:0,“y”:0,“color”:600084223,“width”:2,“height”:2,“tabId”:0,“deviceId”:0,“pin”:-1,“pwmMode”:false,“rangeMappingOn”:false,“min”:0,“max”:1,“pushMode”:true}],“devices”:[{“id”:0,“name”:“New Device”,“boardType”:“NodeMCU”,“token”:“e8509f285b374b8cb08f3165b93c96c2”,“connectionType”:“WI_FI”,“status”:“OFFLINE”,“disconnectTime”:0}],“theme”:“Blynk”,“keepScreenOn”:false,“isAppConnectedOn”:false,“isShared”:false,“isActive”:false}

upload new token and checked ip in my sketch, upload this and get the same result:
Connecting to 139.59.206.133

@hills8

Correction, the server is the last parameter so it becomes:

Blynk.begin(auth, ssid, pwd, server);

Hi!
When I do this, I get “Invalid Token.”
Thanks!