Nodemcu esp 8266 error login timeout

Hello, im newbie at iot, this is my first time build a project, and im making a “internet lamp” with nodemcu, relay, and blynk

And then im uploading the sketch into my nodemcu, succesful but when i check it from serial monitor it always said this :
402250] Login timeout
[405250] Connecting to blynk-cloud.com:80
[410588] Connecting to blynk-cloud.com:80
[416015] Connecting to blynk-cloud.com:80
[421442] Connecting to blynk-cloud.com:80
[426971] Connecting to blynk-cloud.com:80
[429296] Login timeout
[432296] Connecting to blynk-cloud.com:80
[434621] Login timeout

And here is my code :

#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "c23600412c774d2c86a3302eba******";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "******";
char pass[] = "*******";

void setup()
{
  // Debug console
  Serial.begin(9600);

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(172.20.10.10), 8080);
}

void loop()
{
  Blynk.run();
}

I saw many thread from this website with the same issues like me, but they have a different solution, the first person he said solved by changing the dns, the 2 person said he change the network, and the 3 person said he change the isp port

Please somebody help me, im not an it guy and im so confuse with these issues

It’s possible that your ISP is blocking the Blynk traffic. Try it with another internet connection, maybe at a friend’s house.

Pete.

1 Like

Solved thanks :grin: