No Connection with new blynk in Spain

Hello together,
I’m in Spain right now and wanted to try out my first old prgramm with the new app.
Everything worked in Germany, but here in Spain Blynk does not connect.
Output on the serial monitor:
[3829] Connecting to
[9832] Connecting to
WiFi.status() says 3
Ping is executed for [] with 32 bytes of data:
Response from Bytes=32 Time=53ms TTL=47
Response from Bytes=32 Time=99ms TTL=47
Reply from Bytes=32 Time=57ms TTL=47
Reply from Bytes=32 Time=55ms TTL=47

Here is the code for Wifi

void MyWiFi() {
  int mytimeout = millis() / 1000;
  WiFi.config(arduino_ip, dns_ip, gateway_ip, subnet_mask);
  WiFi.begin(ssid, pass);
  while (WiFi.status() != WL_CONNECTED) {
    if ((millis() / 1000) > mytimeout + 2) {
 // delay(100);
  //Blynk.config(auth, "", 80); //Blynk.begin(auth, ssid, pass);
  // Blynk.config(auth, "", 80);
  mytimeout = millis() / 1000;
  while (Blynk.connect() == false) {
    if ((millis() / 1000) > mytimeout + 3) {

If the Wifi connection is interrupted or not available, the execution of the programme should not be stopped.
This code has worked wonderfully so far, only the connection to Blynk was established with Blynk.config(auth, “”, 80);.

It would be great if someone could help me.
Many greetings Uwe

The problem seems to be with the TP-Link router.
I have now documented the following line

 // WiFi.config(arduino_ip, dns_ip, gateway_ip, subnet_mask);

I now connect Wifi without specifying the IP.
I bind the IP via the Mac address on the router.
The connection works again.
Greetings Uwe

If you’re using an ESP8266 or ESP32 then the correct syntax is:

WiFi.config(local_ip, gateway, subnet, dns1, dns2)

Also, if your device is attempting to connect to (the IoT server)…

Then I don’t see the value in pinging (the Legacy server)…


Hi Pete,
thanks for your help.
I’m just wondering why the same code ran with the old app…
but anyway, it works now.
My first ESP is online with the new Blynk and it seems that everything works.
Thanks a lot
Greetings Uwe