New to Blynk - Unsure what is happening

So, I am programming a NodeMCU 1.0 (ESP-12E) ESP8266, and attempting to do the QuickStart. I’ve tried both with the Ardunio IDE and PlatformIO.

I have installed the necessary libraries, and the code compiles and uploads to the device. When I then check the serial device, I get this:

[5915] Connected to WiFi
[5915] IP: 192.168.1.105
[5915] 
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v1.2.0 on ESP8266

 #StandWithUkraine    https://bit.ly/swua


[5926] Connecting to blynk.cloud:80
[6069] Invalid auth token
3fffff50:  0000464f 00000000 3ffeefe8 40201149  
3fffff60:  00000000 00001f93 97ced916 002482a7  
3fffff70:  00000000 000000bb 3ffef058 00001725  
3fffff80:  0000464f 3ffeefb0 00000000 402022e3  
3fffff90:  40207d80 6901a8c0 feefeffe feefeffe  
3fffffa0:  feefeffe feefeffe feefeffe 3ffef1e0  
3fffffb0:  3fffdad0 00000000 3ffef1b4 402049a4  
3fffffc0:  feefeffe feefeffe 3fffdab0 40100e75  
<<<stack<<<

--------------- CUT HERE FOR EXCEPTION DECODER ---------------

 ets Jan  8 2013,rst cause:2, boot mode:(3,7)

load 0x4010f000, len 3424, room 16
tail 0
chksum 0x2e
load 0x3fff20b8, len 40, room 8
tail 0
chksum 0x2b
csum 0x2b
v00046e20
~ld
����g�s��g|�d�l b�e�|;�l�o��o�l ��{�d�le��[91] Connecting to Blackrock

I can see it connecting to my router, but when I go to the Blynk Console, it shows offline.
Any ideas, or can you point me in the right direction?

Patrick


Update: Thanks to Pete’s suggestion, I went back and started over. Turns out what I did wrong was copy and paste the code which I didn’t realize had a new Auth Token when it was regenerated, as this wasn’t mentioned and I didn’t look at the code close enough when running through the QuickStart.

So, once I followed the directions (instead of switching back and forth between two IDE’s) it worked fine.

Thanks for the help and support Pete!

I’m not sure what you’ve done, but the auth token you are using is incorrect.

Pete.

I saw that but have no clue either.

I suggest that you start by using the web console to delete the QuickStart device and template that should have been created by going through the QuickStart process.

Then, do the QuickStart over again, copy the code that it generates and paste it into your IDE and upload it to your device.
Ensure that you compete the Quickstart wizard completely, otherwise the necessary device and template won’t be created.

Pete.

1 Like

Will do. I do that tonight and report my results. Thanks for taking a look.

Patrick

Well Pete, that helped. I see now where the Token is coming from, and after deleting and starting over, it worked initially. The device was briefly online, although it didn’t do anything, but I’m studying the code now that I’m awake to see just what I should be expecting. But within a minute it went offline.

But progress. :smile:

The code that the QuickStart wizard generates automatically inserts the Auth token, along with the template name and ID, into the sketch, so you don’t really need to know where it comes from.

What does your serial monitor output show know, when you reboot the device?

Pete.

It’s all good now Pete.

It’s working just as it is supposed to.