Network shield recommendation

I’m a newbie having great initial success with blynk and mega 2560, but my project is stuck because of problems with the CC3000 wifi shield I’m using. As others here have complained, the CC3000 keeps losing the connection randomly. I’ve upgraded the firmware, as others have suggested, but still no luck - it still drops the connection at random intervals. I’m thinking to switch to a different shield that is more stable - wired ethernet would be fine. Does anybody have a recommendation? It should be: 1) compatible with blynk, 2) compatible with mega 2560, 3) sufficient info available on it that a newbie like me can get it to work. I bought a Seeed Ethernet Shield V2.0 today from Radio Shack, and could not even get it to read from a web site, which I had no trouble doing with the CC3000. I am probably doing something wrong, but I couldn’t find much info about that shield on the web, and I’m too inexperienced to know how to fix the problem myself. Any suggestions for a different shield or a solution to either the Seeed or CC3000 would be appreciated. My project was very far along, but it’s useless if it can’t stay connected.

Dear @mnw

I use the standard Arduino WiFi shield https://www.arduino.cc/en/Main/ArduinoWiFiShield101 connected to the UNO board but it also works with the Mega board.

Blynk has been up and running uninterrupted for several weeks now, monitoring parameters in my kitchen garden and reporting data to the App.
Another shield is in my living room with an IR emitter controlling devices, so in this case the App is sending parameters to the hardware. Both systems are very stable with Blynk.

I have never had a CC3000 board to compare it to, but the Arduino WiFi shield has always worked well for me. I have tried other projects that report data to servers such as ThingSpeak for instance and again, no issues. Of course there were rare occasions when it disconnected but, even my phone that is made by the most valuable company in the world has at some point also lost its connection. Not bad for a 50 dollar shield. :wink:

The WiFi shield has been around for years and there’s loads written about it online to get you out of trouble.

Cheers

Thanks for the suggestion! I just ordered one. Wish me luck!

Arduino official Ethernet shield
Particle Photon
Sparkfun Photon RedBoard

I would not recommend using CC3000 because of numerous stability issues

Not to hijack the thread, but the Arduino WiFi shield and the WiFi101 shield are different shields and I am having trouble finding a working sketch for the wifi101 shield. If that is the shield you are working with can you advise me on how you got this to work and what libraries you used. thanks

You’re not hijacking the thread - this is indeed about Wifi101. I too am having trouble with WiFi101. murilopicanco kindly suggested I get the WiFi101, which I did. Unlike the CC3000, it does indeed stay connected to wifi without dropping as he said it would, but I could not get it to connect to an ntp time server. The example sketch provided doesn’t work - this issue has been mentioned in other forums. Since my project depends on time access, I’m stuck. If anybody has suggestions, let me know. cspearsall, what are you trying to do that didn’t work?

Thanks for the suggestions, but before seeing your reply, I already ordered an official WiFi101 shield based on the other user’s suggestions. It is very stable, but it could not fetch ntp time server info, even using the example sketch. This issue is mentioned elsewhere. I’m becoming frustrated, because I’m a newbie, and with each shield I’ve tried, some things work, and some don’t. Everything worked with CC3000, but it kept dropping the connection. You think I can get ntp, http client, and blynk to all work with the official ethernet shield? I’m willing to try it, but after having the example sketch for official WiFi101 and official Arduino Mega, I’m not optimistic.

mnw - I cannot get the WiFi101 shield to connect at all…there are not Blynk libraries created for this shield yet and I am too much of a noobie to use the user defined connection. I received a response in this forum under another post regarding the WiFi101 shield that follows:
From: vhymanskyy Blynk Embedded Architect

Yes we will support it, in some time. We don’t have it yet, so can not start integration…

Have you been able to get it to connect to Blynk, because I have tried two shields the CC3000 and the WiFi101. The CC3000 will not stay connected and the WiFi 101 which will not connect at all…

Dear @cspearsall,

I think @murilopicanco was confused. He said he had good luck with blynk using the WiFi shield and gave a link to the WiFi101, so I bought it. Unfortunately, I think he meant the older WiFi shield. I’ve had no luck with the WiFi101. I’ve now gone through three different brands of shield and none will do everything properly. CC3000 worked across the board, but would not stay connected. WiFi101 could not interact with ntp time server, and now you are saying you can’t use it with blynk. With the Seeed ethernet shield from Radio Shack I couldn’t get anything to work. I think I will next try the Arduino official Ethernet shield as suggested by @Pavel above.

mnw,
I agree with you. My CC3000 works but will not stay connected long (interestingly it stays connected longer when using ecternal power source then it does when powered through usb tether), my WiFi101 will not connect at all. I have had 100% success with the Arduino ethernet shield, so if you do not mind being tethered to an ethernet cable then that is the best choice. I am looking for a wireless solution, so it would appear that I need to buy an official Arduino Wifi shield (it’s a shame that they are so expensive)

We will add it definitely, but it takes some time…

Hello @mnw

I’m sorry for the confusion. The link should have been for the Arduino WiFi shield I mentioned in my post and not the 101 shield.
I have 2 Arduino WiFi Shields running separate projects in Blynk and the stability is remarkable with the Uno board.

This past week I have also tested the Arduino Yùn and it has been running for 5 days without interruptions.

Cheers

1 Like

Thanks for good feedback :wink:

After many unsuccessful experiences with Ethernet and WiFi shields, I found one that works perfectly, and it’s stable and cheap (thanks to @cspearsall for the recommendation.) Here’s a link:

hey,

I use this shield directly from china on my uno and mega’s:
http://www.aliexpress.com/item/UNO-Shield-Ethernet-Shield-W5100-R3-UNO-Mega-2560-1280-328-UNR-R3-only-W5100-Development/32341820750.html

It works and costs nothing. Reconnects instantly when power is hooked, never loses connection and all you do is plug it in; No firmware, updates, sketches, librairies. Just plug and playfor 5 dollars
:slight_smile:

I dont like to do propoganda for China. I feel like real arduino products should be supported to support the development of the whole platfform. But if ur gonna by a chinese counterfeit, order it from aliexpress like i showed in my link. Its a fourth of the price for the same product. the extra 17 dollars on amazon gets you slightly faster delivery but goes straight in the pocket of someone else ordering from aliexpress. Might as well buy 3 and donate the rest of the profit to arduino or blynk :slight_smile:

1 Like

Well, it doesn’t matter - I spoke to soon. Like the other 4 shields I’ve tried, this one has gone flaky as well. I thought maybe it was my code, but now the unmodified example sketches don’t work smoothly. I’m kind of confused about the whole arduino thing at this point. I’m not sure what other people are doing so that their projects can connect reliably (and stay connected). Has anybody else encountered so many problems?

I have no association with Blynk but honestly this is all I did:

  1. Buy ethernet shield from link I gave
  2. stack shield on fake arduino mega (same site), 6 dollars
  3. Copy pase blynk librairy in c/\programfiles\arduino\libraires
  4. download app to smartphone and create one button for pin 13
  5. stick led in gnd and pin 13 of mega
  6. request token in app
  7. Open arduino ide with my mega connected through usb and upload example sketch blynk > ethernet example with my token in the 'my token" part of the example sketch
  8. everytime my app and arduino are on, it now just wokrs. It didnt take more than 5 minutes

If this does not work with you I strongly recommend:

a) reinstall latest arduino ide after completely deleting all files and librairies
b) Add blynk librairy again (drag and drop the unzipped “blynk” folder)
c) request new token in app for your sketch. make sure u paste this token correctly
D) try with an arduino uno first iF you have one. Most shields are designed for uno but SHOULD work on mega
E) try with any other board for that matter, to see if it isnt just ur arduino that s flaky. An uno costs 3 dollars from aliexpress, no reason not to get one just to be sure… An uno style board (wemos D1 costs 7 dollars with wifi built in, but i m waiting for blynk to confirm that this will work)
F) try with ur blynk app in shield connected to the same stable network (not 4g) to make sure.

I hope u get it working bro :slight_smile:

also make sure ur ethernet cable is in good condition and pliugged in (duh i know) and avoid having more than an led connected to ur mega for testing purposes. I find sometimes complicated circuits make me arduinos not upload sketches correcctly but uploading always goes smooth with just an led to pin 13 and GND (same pin that blinks onboard led when starting the mega up so you always know ur led is still working too)

U mention u did not edit ur sketch this time. Make sure u pasted ur token correctly! (I think the quotation marks need to stay).

Also make sure U choose arduino mega in the blynk app when u created the sketch and no other arduino