Need Help in webhook, IFTTT

I am working on home automation system, i have successfully made connection from Blynk app to the relay, but facing the problem while attempting to control the relay through the google assistance, please suggest me how can to overcome this problem. In the URL side of the web-hook i used the following formats but nothing is working.

Is there any alternative way to do this? i am working from Saudi Arabia. if any fellas have suggestion please let me know.

Thanks & Regards,

I don’t see any values for your pin… try write pin value via GET

Hello Gunner,

Thank you for your quick response. i made the changes as per your advice, still its not working. please see the screen shot and suggest whats gone wrong here.


I don’t know for sure (I don’t use the method)… but try https (if it matters) and the GPIO pin designation instead of the silk screened reference. D0 would be GPIO 16

No Gunner, it did not work :frowning:

Can you share a sample screen shot of how you would do this.

it really helps me if you share it.


Search this forum for keywords… perhaps IFTTT? :wink:

Try with PUT instead of GET maybe…!

This configuration is working for me.

Use the url provided by rest api and just put that in the URL field of the Maker Webhook and you should be good. no need to put anything in body just put this in the URL field. also read the topics before asking such questions.

Mr. Khurana…

I read the topic before posting my question here and even tried your way to solve this but it is useless nothing changed. BTW this forum is created in the interest of sharing issues and solving them. So next time pease dont act like a smart jerk.

i was just trying to help. i can even go ahead and help you out via team viewer. i faced a similar problem 1.5 years back and i found the solution in the community itself. PM me and i am ready to help you out

It also has rules and recommendations to search first and RTFM :stuck_out_tongue_winking_eye:

So next time please follow your own advice and respect the other users who are actually willing to respond to your issue and offer sage advice.

Use this method and i am sure you can access google assistant with that.
It’s work for me…

I’m facing a very similar issue, Can some one help me with this ?
Google home voice assistant is not turning on my led

I’d switch to using GET instead of PUT.
See this post for the syntax:

Also, if you’re using an ESP/NodeMCU device then GPIO0 isn’t the best pin to use:


Thank You PeteKnight appreciate your reply :slight_smile:


@Gunner can you mark this topic as solved.