My Blynk App does not connect to my Arduino Mega

I am using Dragino-Yun shield on Arduino Mega2560. Following is the process I have gone through;

  1. When I first powered up the Dragino-Yun, its wifi ip-address was 192.168.240.1
  2. I configured Dragino-Yun shield to connect to my wifi modem (wifi ID & WPA password) and restarted
  3. IP-address 192.168.1.2 is assigned to Dragino-Yun by the wifi modem
  4. I connected DHT11 sensor output to pin 21
  5. I created a sketch (DraginoDht11.ino) which sends DHT11 humidity & temperature data to the console every 2 seconds
  6. It worked fine
  7. I created a Blynk App and placed two Gauges on it (at V5 & V6) to receive and display temperature & humidity values from my Arduino sketch
  8. Now I created another sketch (BlynkDht11.ino) to send data to the Blynk App running on my Samsung Tablet which is connected to the same wifi modem
  9. I copied the authorization code to the sketch
  10. Sketch compiled and downloaded to the Arduino Mega2560 through wifi modem using Dragino-Yun shield
  11. Now when I run the App it says “Your Arduino Mega is not in network”

I tried hard but failed to understand what I am doing wrong.

My DraginoDht11.ino code is as under;

#include <Console.h>
#include "DHT.h"

#define DHTPIN 21           // what pin we're connected to
#define DHTTYPE DHT11       // DHT 11 

const int ledPin = 13; // the pin that the LED is attached to
int incomingByte;      // a variable to read incoming serial data into
uint16_t sNo;          // Serial number of reading

DHT dht(DHTPIN, DHTTYPE);   // Initialize DHT sensor for normal 16mhz Arduino

void setup() {
  // initialize serial communication:
  Bridge.begin();
  Console.begin(); 

  while (!Console){
    ; // wait for Console port to connect.
  }
  Console.println("You're connected to the Console!!!!\n\r");
  Console.println("DHTxx test!");
  pinMode(13, OUTPUT);
  dht.begin();
}

void loop() {

  delay(2000);

  // Reading temperature or humidity takes about 250 milliseconds!
  // Sensor readings may also be up to 2 seconds 'old' (its a very slow sensor)
  float h = dht.readHumidity();
  // Read temperature as Celsius
  float t = dht.readTemperature();
  // Read temperature as Fahrenheit
  float f = dht.readTemperature(true);
  
  // Check if any reads failed and exit early (to try again).
  if (isnan(h) || isnan(t) || isnan(f)) {
    Console.println("Failed to read from DHT sensor!");
    return;
  }

  // Compute heat index
  // Must send in temp in Fahrenheit!
  float hi = dht.computeHeatIndex(f, h);
  sNo++;
  Console.print(sNo);
  Console.print(". Humidity: "); 
  Console.print(h);
  Console.print(" %\t");
  Console.print("Temperature: "); 
  Console.print(t);
  Console.print(" *C ");
  Console.print(f);
  Console.print(" *F\t");
  Console.print("Heat index: ");
  Console.print(hi);
  Console.println(" *F");
}

My BlynkDht11.ino code is as under;

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <SPI.h>
#include <Ethernet.h>
#include <BlynkSimpleEthernet.h>
#include <SimpleTimer.h>
#include <DHT.h>

char auth[] = "********************************";

#define DHTPIN 21          // What digital pin we're connected to
#define DHTTYPE DHT11     // DHT 11

DHT dht(DHTPIN, DHTTYPE);
SimpleTimer timer;

void sendSensor()
{
  float h = dht.readHumidity();
  float t = dht.readTemperature(); // or dht.readTemperature(true) for Fahrenheit

  if (isnan(h) || isnan(t)) {
    Serial.println("Failed to read from DHT sensor!");
    return;
  }
  Blynk.virtualWrite(V5, h);
  Blynk.virtualWrite(V6, t);
}

void setup()
{
  // initialize serial communication:
  Serial.begin(9600); // See the connection status in Serial Monitor
  Blynk.begin(auth);

  dht.begin();

  // Setup a function to be called every 2 second
  timer.setInterval(2000L, sendSensor);
}

void loop()
{
  Blynk.run(); // Initiates Blynk
  timer.run(); // Initiates SimpleTimer
}

After further detailed analysis of the DSL router and DHCP server within it, it seemed that, apparently, there is no problem on network side. My Wifi supports WPA & WPA2, There is no active firewall on the router. But when I try to connect my Windows10 computer through TELNET to blynk-cloud.com:8442, it simply says “Connection to host lost”. Following are some screenshots. RBB is the Dragino Yun identity in the DSL wifi modem’s DHCP client.

Further attaching Dragino-Yun configuration screenshots

No one seems to have any suggestions about my problem :unamused:

only @vshymanskyy may know if that shield is supported.

Also did you try simplest possible sketch without DHT?

Thanks for the reply. I didn’t know if there is some issue with Dragino-Yun shield. However, I did try the simplest on/off first. It didn’t work either.

In my 2nd post, I included a screenshot of my telnet session in which there is no response from the blynk-cloud.com:8442. Is this normal behavior for a general telnet request?