My arduino mega is not connecting to blynk

I am having problem connecting my Arduino mega with blynk server. It was working well for a day and now It’s not connecting, So I connected it to my laptop to have a loot into serial monitor. And here’s log -

[0] Getting IP…
[5630] My IP: 192.168.1.103
[5630] Connecting to cloud.blynk.cc:8442
[20656] Connecting to cloud.blynk.cc:8442
[35676] Connecting to cloud.blynk.cc:8442
[50696] Connecting to cloud.blynk.cc:8442
[65716] Connecting to cloud.blynk.cc:8442
[80736] Connecting to cloud.blynk.cc:8442
[95756] Connecting to cloud.blynk.cc:8442
[110776] Connecting to cloud.blynk.cc:8442
[125796] Connecting to cloud.blynk.cc:8442
[140816] Connecting to cloud.blynk.cc:8442
[155836] Connecting to cloud.blynk.cc:8442
[170857] Connecting to cloud.blynk.cc:8442
[185877] Connecting to cloud.blynk.cc:8442
[200897] Connecting to cloud.blynk.cc:8442
[215917] Connecting to cloud.blynk.cc:8442
[230937] Connecting to cloud.blynk.cc:8442
[245957] Connecting to cloud.blynk.cc:8442

It’s trying again and again to connect. I don’t know what the problem is. It was working well couple hours ago.

I checked the port 8442 (which blynk uses to communicate ) on a site- https://www.yougetsignal.com/tools/open-ports/ And it’s telling me that port 8442 is closed for ip address. Is that a problem?

Those W5100 ethernet shields can be problematic. You can try the USB link option to confirm if the issue is in your code (if you have been changing things) or the hardware.

http://help.blynk.cc/how-to-connect-different-hardware-with-blynk/arduino/usb-serial

Your hardware is actually connecting to that port on the Cloud Servers end, not the port on your router (which that site is checking), so that shouldn’t be an issue.

You have very outdated library.

That server was retired 18 months ago. Try not to study old tutorials.

@Dmitriy can you please provide me link for latest one?

1 Like

Oh, wow… I missed that one. I blame that on my running a Local Server almost since day one, and thinking the OP’s failure “just suddenly happened” as opposed to “stopped working after messing with something:stuck_out_tongue:

Thanks I was already using latest library. I solved problem by uploading Blynk sketch again on my Arduino.

But now I’m facing a different problem that when there’s a power cut my Arduino doesn’t start automatically. It starts when I press Reset button. What could be the possible reason?

And I would like to Thank blynk community for helping me quickly.

This was already answered in one of your other topics… I had provided some info and links in the latter part of this post…

@Jivan there are a couple of possible issues involved and they have been covered recently on this site:

  1. Inadequate PSU and you need to resolve this.
  2. Inappropriate code i.e. network not declared before Blynk.begin(), try searching for most recent posts regarding the following terms W5100 BlynkNoBlock and brown out.