Mobile app showing device offline

Hello everyone! This is my first project with blynk app. I am trying to connect my android device with the Arduino UNO board, with help of USB (without shield). My laptop has Ubuntu OS in it. I have connected my laptop with my mobile hotspot. After uploading the code into the UNO board and run the app in my mobile, I am getting Device offline. What should I need to do to connect my blynk app with Arduino UNO board.

The program that I have used is a simple example program for USB connection.

#include <SoftwareSerial.h>
SoftwareSerial DebugSerial(2, 3); // RX, TX

#include <BlynkSimpleStream.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "7F20nim-JQ0X2_i5L9oI9Ez4r7xZWHo4";

void setup()
  // Debug console

  // Blynk will work through Serial
  // Do not read or write this serial manually in your sketch
  Blynk.begin(Serial, auth);

void loop()

I have tried many times, but it is still not working. Please help.
Thanks in advance!

Are you running the USB script on your laptop?
Have you edited the script at all?
What do you see on your command/terminal window?


In the terminal, I was in the scripts folder of the blynk library. I ran, ./ to setup the port and the port to which I connected the arduino board was visible in the terminal. Everything was fine. I exited the terminal, uploaded the code into the arduino board, and when I opened the app in my mobile, it still showed Device offline.

Do you think that this gives sufficient information to allow one of the Blynk community members to help you to resolve your problem?


Sorry for that. I didn’t get your question before. What were you asking?

This is a straight forward yes/no answer.
If the answer is No then you’ve not followed the instructions correctly.

Also a straightforward yes/no answer, but which requires you to add some detail if the answer was Yes.

Copy the contents of the command/terminal window that you see when you run the script and paste the results into your reply, with triple backticks at the beginning and end so that it displays correctly.
Triple backticks look like this:

Clearer now?