Map resolution problem

Hi, Does anyone have an idea why the track on the map is showing so many steps? and is not aligned with the roads. I am using neo6m GPS module.

Presumably you are sending low resolution GPS coordinates (a small number of decimal places in the long and lat values).


Here is a part of a code from Arduino that is reading and sending coordinates to Blynk.

float latitude =;
float longitude = gps.location.lng();

Blynk.virtualWrite(V3, longitude, latitude);

How often are you taking these coordinate readings from your GPS and sending them to Blynk?


I am sending it each second. Also if I look at the time stamp in Blynk.Console “Updated at” it is increased each second.

#define INTERVAL 1000L
timer.setInterval(INTERVAL, sendGps);

If I look into datastreams it is strange to me that for location datastream V3 only 3 decimal places are displayed. For V1 and V2 latitude/longitude I can select and display 5 digits.

Have you tried adding serial print statements to see what latitude and longitude look like immediately before you send them to Blynk?

Does your GPS library allow you to specify resolution?


It seems like the compiler rounded off coordinates to 3 decimal places. I solved the problem with direct call of gps.location… now it works.
Blynk.virtualWrite(V0, gps.location.lng(),;

I was always sending also coordinates to serial port and I got all 6 decimal places.

Now I replaced TinyGPSPlus library with TinyGPS and I got the same problem that coordinates are rounded up to 3 decimal places. Why should this happen if both are defined as float and correctly displayed on SSD1306 and on the serial terminal (with 6 or 7 decimal places)? But in Blynk there are only 3 again. I am using Blynk.virtualWrite(V0, longitude, latitude);