BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Make local blynk server public

esp8266

#1

Hello all!

I’ve created a local blynk server sucessfully for the reason of upping the user.message.quota.limit.
Now i need to make that local server public. So when my phone is connected to 4g instead of the local network i need access to the server.
My connection looks like this when i’m on the same network.
Ip:192.168.0.xx
Port:9443

I’ve figured that i need to port forward on my router, which i’ve tried to no avail. The ports i’ve tried: 9443, 8441-8444, 843.
I’ve also changed my ip in APP to global ip.

I have the following required fields on my router for port forwarding;
Protocol
External Host
External Port
Internal Host
Internal Port

What i’ve done so far is
Protocol = TCP/UDP
External Host = My global ip on my computer)
External Port = (Port 9443, 8441-8444, 843)
Internal Host = My local ip on my computer
Internal Port = Same as external Port

Cheers!


#2

I don’t think this is correct. What you’re being asked to define here is ‘which external IP and ports should I be looking at, and when I recieve data from those, what should I do with it.
By specifying the external IP address of your PC, you’re in effect saying that only data that comes from that IP address should be forwarded. What you actually want to do is forward data from the IP address of your phone when it’s connected to your cellular network. Obviously you don’t know what that IP address will be, and it will change dynamically over time. So, what you probably need to define here is ‘Any IP address’. How you do this will depend on your make/model/firmware version of your router, but it may simply be a case of specifying ‘Any’ or using wildcards. The help guide for your router may help with acceptable options.

It may also be worth you reading this thread:

Whilst the whole thread will be of help to you, post number 30 onwards has some useful info about how some ISPs use a double NAT system which prevents you from achieving what you want to. The thread gets a bit messy, but it does explain how to find out if your ISP is using double NAT.

Pete.


#3

Hi,

Thanks for the link. I opened cmd and typed the following command :
route print -4
It seems that i only have ip addresses within the private range.
I’ll have to check with my isp provider tomorrow!