Lost BLE connection using ESP-32 Dev Kit C V4 on Android

Hello
I’ve made a project using ESP-32 Dev Kit C V4 and a BME280
Using BLE, blynk lost connection on my phone when i use an other application.
Bluetooh icon is always blue.
Have to reset ESP32, shutdown Blynk app and reopen it to connect bluetooth.

Blynk library version: [0.6.7]
IDE: [Platformio with vscode on Ubuntu 21.04]
IDE version: [1.57.0-insider]
Board type: [ESP32 Dev Kit C V4]
Additional modules: [BME280]
Blink version : 2.27.29

#define BLYNK_USE_DIRECT_CONNECT

#include <Arduino.h>
#include <BlynkSimpleEsp32_BLE.h>
#include <BLEDevice.h>
#include <BLEServer.h>
#include <Adafruit_Sensor.h>
#include <Adafruit_BME280.h>
#include <SPI.h>

//Blynk
const char *auth = "xxxxxxxxxxx";
BlynkTimer timer;
void ReadSensors();

//BME280
#define SEALEVELPRESSURE_HPA (1013.25)
Adafruit_BME280 bme;
float temperature, humidity, pressure, altitude, altIGN = 481.38, pnmm;

void setup() {
  
  Serial.begin(115200);
  Serial.println("Connexion...");
  bme.begin(0x76);
  delay(100);
  Blynk.setDeviceName("ESP32-12F BME280");
  Blynk.begin(auth);
  timer.setInterval(5000L, ReadSensors);   // read sensor every 5s
  delay(100);
}

void loop() {
  
  Blynk.run();
  timer.run();
}

void ReadSensors() {
  //Read values from the sensor:
  temperature = bme.readTemperature();
  altitude = bme.readAltitude(SEALEVELPRESSURE_HPA); //Change the "1050.35" to your city current barrometric pressure (https://www.wunderground.com)
  humidity = bme.readHumidity();
  pressure = bme.readPressure() / 100.0F;
  pressure = pressure * exp(9.80665 / (287.05 * (temperature + 273.15 + 0.12 * humidity + 0.0065 * altIGN / 2)) * altIGN);


  Blynk.virtualWrite(V1, pressure);   // write pressure to V1 value display widget
  Blynk.virtualWrite(V2, temperature);  // write temperature to V2 value display widget  
  Blynk.virtualWrite(V3, humidity);
  //Blynk.virtualWrite(V4, altitude);  // write altimeter to V3 value display widget
  Blynk.virtualWrite(V4, altIGN);
}

If it can help.
Have this in terminal

Connexion…
[249]
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v0.6.7 on ESP32

[20329] BLE connect
[22234] Ready
[41735] BLE disconnect
[41735] Disconnected

I saw there is a beta version 1.0.0-beta.3
How to add it in platformio.ini ?

You should be using 0.6.1

Pete.

Thanks for help
But same issue with 0.6.1