Log in problem


I am new to the community and this is my first post.

I have installed a local Blynk server on my Windows 10 computer.

My problem is that I can not log in to the admin page at https://localhost:9443.

I get a response and can enter the email adress admin@blynk.cc and the default password.

After that nothing happens except thar the login box appears again with empty email adress and password field. It looks like the password enter was not valid. However I get no errors or other messages.

Have I missed something obvious here?

I have the searched for similar problems but not actually found anything.

Best regards / Leif

What does you server log show?

Have you tried deleting the admin@blynk.cc.Blynk.user file, restarting you server and trying again?



Thanks for the quick reply.

Where is the admin@blynk.cc.Blynk.user file located?

This is the content of the blynk logfile:

14:29:10.583 INFO - Using data dir ‘C:\Users\TURETU~1\AppData\Local\Temp\blynk’
14:29:10.880 INFO - Region : local. Host :
14:29:11.192 INFO - Initializing gmail smtp mail transport. Username : example@gmail.com. SMTP host : smtp.gmail.com:587
14:29:11.235 INFO - Reports : 0
14:29:11.235 INFO - Didn’t find custom user certificates.
14:29:11.235 INFO - Didn’t find Let’s Encrypt certificates.
14:29:11.235 WARN - You didn’t specified ‘server.host’ or ‘contact.email’ properties in server.properties file. Automatic certificate generation is turned off. Please specify above properties for automatic certificates retrieval.
14:29:11.235 WARN - ATTENTION. Server certificate paths (cert : ‘C:\Users\Ture Turbin\Blynk’, key : ‘C:\Users\Ture Turbin\Blynk’) not valid. Using embedded server certs and one way ssl. This is not secure. Please replace it with your own certs.
14:29:11.786 INFO - HTTP API and WebSockets server listening at 8080 port.
14:29:11.786 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
14:29:11.786 INFO - Mqtt hardware server listening at 8440 port.

Best regards / Leif

I don’t know on a Windows server, I only have experience of running local server on the Pi

At what point (time) in the period covered by the log file did you try to log-in via the web portal?

You may need to increase the logging-level by changing the setting in the server.properties file and restarting the server.



OK, there is no server.properties file so I guess the Blynk server goes with default values.

I have tried to login several times over a persiod of several hours and all I get is the same log in box.

Best regards / Leif

Okay, you need to create a server.properties file as described here:

and populate it with the values from the example.

You then need to restart the server, and depending on where you place the server.properties file you may need to specify it’s path in your server startup command.