LCD not working?

Hi all,
I used the example code of the LCD widget, put my own auth code blah blah blah but nothing is coming up on the LCD with the app? I placed the LCD into advanced mode on V1 but still no go, what else could it be? cheers in advance.

Hardware Used:
Arduino Uno Rev 3
Arduino Ethernet 2 Shield

Hello. iOS, Android? Latest version? Did you select Pin correctly?

iOS, yes latest version, and I didnโ€™t quite understand in the example where the pin selection is undertaken. All i read is in the setup up top of the example that it tells you to put LCD widget on pin V1 and I assumed because there is only one pin stated that the widget within the app had to be on advanced.

Yes. This is correct. So you select in Widget pin V1? And in code you have

WidgetLCD lcd(V1);


ahhh thats where i think it goes wrong, in example is has this instead:

WidgetLCD lcd(1);

This is same. We need to be sure. App pin is equal pin in sketch. Did you run your project (press run button)?

hi dmitriy, yes I have checked both app and sketch and tried it with the WidgetLCD lcd(1) and WidgetLCD lcd(V1) and no difference, text does not show up inside the app.

Does other widgets works for you?

Yes, joystick works to control servos, then I upload the different code which is the example code for using the LCD and no go.

Well, all seems works fine on our side. Did you change somehow default sketch? Maybe added something? Changed x, y?

The only changes to the original example sketch was the Auth Code

What iOS version do you have and what device do you use?

iPhone 6S running iOS 9.2

Ok. Confirmed. Update is on itโ€™s way.