Issues with Blynk Connection

I have been working in a project using DHT 11, CO sensor MQ-7, Gas sensor MQ-2, 2 LEDs and a buzzer linking with my android phone to monitor the status. At first, I did successfully and was about to report it to my teacher but in my final checking, it doesn’t work anymore. All the codes are the same, I do the same every step that I did, nothing unsual happens but I doesn’t work. The app Blynk on my phone can’t connect to my project, it shows “Device is offline”. Please help me

I think I have the similar issue. I am using a Wemos D1 mini, and the Blynk Blink sketch from the examples. I upload the firmware, and it works. I create a new project in the app and I can control the relays connected to the ESP.
If I unplug the ESP and plug it back again, it will never ever connect to the server again.

If I upload the sketch again, it works again until the next reset or poweroff. On the other hand, the serial monitor is only telling me good thinks, like:
[83391] Ready (ping: 1ms).
[83427] Connecting to
[83850] Certificate OK
there is no a single error message anywhere, but still the device is offline in the app. Quite disappointing.

@MinhTri you didn’t specify your hardware or how you are connecting to the cloud server. What worked at home may not work on another access point (school) without significant reconfiguration.

@Csongor_Varga If you are wishing to provide more details on YOUR issue, then please create YOUR OWN topic for it… You issue does not sound similar (unless you also took your project to school and had it fail :wink: )

Ops I’m sorry, I use adruino UNO R3, connect via Usb Serial. I had a old project​ that had same device and faced with same problem. It worked at home, didn’t work at school. However I used laptop and phone of my friend with the same codes​ and device, I worked again.

Blynk uses a centralized server (Cloud or Local) based system:
App <-internet-> Cloud Server <-internet-> Hardware (UNO)

The USB script simply turns your PC into an oversized ethernet adapter that allows a basic Arduino to connect to the internet.

But as you discovered, the PC itself still needs unrestricted internet access, and most Schools, Workplaces and even Public WiFi hotspots have firewalls and port restrictions that prevent proper access to and from the Blynk Cloud Server.

Your friend’s laptop with what sounds like a cell phone based internet connection would have had no such restrictions.

Glad you got it working. Did you have any other questions?

1 Like

As Gunner says, those ports are blocked. That is the one thing on the Cloud server which bothers me a bit. An SSL application should connect to 443, not some other port. From the hardwareside it can be a problem because not all hardware has SSL capabilities, but nonetheless, it should then connect over port 80 if you ask me.

Using non default ports can lead to weird firewall scenario’s and non-functioning stuff and it adds nothing to security. Just my 2-cents :slight_smile:

@Lichtsignaal agree. And there is ticket for that :slight_smile: -

However, it may not simple as we have http and https on those ports already.

1 Like

Surprisingly, my project works smoothly… again, even with my own laptop. I really don’t know why. I didn’t do anything. Perhaps, because something was unstable that lead to my problem. However, you should check if anything is unusual. Thank you for your help