Iphone does not connect BLE HM-10 with blynk app

Hello everybody ! I spent many days trying to create a simple application to control a servo motor from my iphone using the At09 Hm-10 Bluetooth module, an arduino mega 2560 and the blynk app.
As a test to verify that everything works, load the code from the blynk library to the arduino and in the app simply add a button to turn on / off the led and the Bluethooth widget to connect to the module.
the problem is that the pp blynk recognizes the module when it is scanning the devices but it cannot link it, so it does not connect.
any suggestions you can give me? Thank you so much

I’d suggest that you start by providing the requested information…

Add details :
• Hardware model + communication type. For example: Arduino UNO with Ethernet Shield
• Smartphone OS (iOS or Android) + version
• Blynk server or local server
• Blynk Library version

Pete.

hi pete! Thank you very much for the quick answer
I give you the information you requested if you need anything else please tell me
Add details:
• Hardware model + communication type: Arduino MEGA2560 with bluethooth hm-10 BLE (supposedly compatible with ios)
• Smartphone: iphone 8 ios version 14.4.2
• local server
• Blynk Library version: 1.0.0 beta.3

I’d recommend downgrading to 0.6.1

Pete.

693 / 5000

Resultados de traducción

hi pete! use the recommended version and continue without being able to connect the bluethooth. I would like to correct information that I provide you before regarding the server, it is not local, the server is: blynk cloud The truth is that I am not doing anything outside of a basic example such as turning a led on and off and I see that they normally work without any problem. I even have problems with the esp8266 esp01 module when I also want to use blynk as the interface of my projects. so I add that maybe it is a problem with the libraries or the token that is assigned to the project. If you need any other information please tell me I would love to be able to use blynk in my projects thanks!

What does the Arduino show in the serial monitor?

Pete.

in the case of bluethooth the serial monitor does not show anything, according to the code it should show (“Waiting for connections …”); I set the baud to 9600 through AT commands.
in the case of esp8266 it says: esp not responding. the module works well because by means of AT commands I can connect it without problems to my wifi network. that same ssid and pass is the one I use in the code provided by blynk.

How have you wired your BT adapter to your Mega, and what sketch have you uploaded to your Mega Don’t forget to use triple backticks when posting your code. Triple backticks look like this:
```

It’s going to get very messy if you start discussing issues with a ESP-01 in this BT topic. I’d suggest that you start a new topic about that issue.

Pete.

BT connection to ARDUINO MEGA:
vcc: 5v
GND: GND
As the code indicates in the line SoftwareSerial DebugSerial (2, 3); // RX, TX
RX: 2
TX: 3
and the code is the following:

#define BLYNK_USE_DIRECT_CONNECT

// You could use a spare Hardware Serial on boards that have it (like Mega)
#include <SoftwareSerial.h>
SoftwareSerial DebugSerial(2, 3); // RX, TX

#define BLYNK_PRINT DebugSerial
#include <BlynkSimpleSerialBLE.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

void setup()
{
  // Debug console
  DebugSerial.begin(9600);

  DebugSerial.println("Waiting for connections...");

  // Blynk will work through Serial
  // Do not read or write this serial manually in your sketch
  Serial.begin(9600);
  Blynk.begin(Serial, auth);
}

void loop()
{
  Blynk.run();
}

I gave you triple backticks to copy/paste, but you’ve used some other characters instead.
Please edit your post, using the pencil icon at the bottom, and correct this.

Pete.

I already re-edited it, sorry I’m a little new to this of the communities

Rx is the software serial receive pin, which needs to be connected to the Tx pin on the BT module, and vice versa.

However, I have absolutely no idea why you would go to the bother of creating a software serial port (which can only work at 9600 baud) when the Mega has three hardware serial ports which can be used at whatever speed you want.

Pete.

I read that you mention of crossing the RX AND TX and I tried it but it didn’t work either, so I will follow the suggestion to use one of the other rx and tx available.
I took the code sketch from the blynk library examples from the arduino ide, I just saw that it is different from the blynk web sketch generator. I will try to use the one generated by the web and with the recommendations it gave me and I will tell you if it worked
I appreciate your patience and the answers to my questions

pete! Good news, it works, I made the connection as you suggested and I connected them in serial3 and it works perfect, with a small response delay, I don’t know if it will be due to the configuration of the BAUD (9600). but it’s nothing to worry about.
I will try to do the same with the esp8266 module
Thanks for the help