iOS finally gets Multiple devices!

Found issue: all virtual pins lost !!

Just a question to learn: why do u say that I’ve violated rules for updating of local server ? I’ve followed your guide: find process number, kill server process and reinstall server …

From docs :

Server update should always go before app update.

just to add a potential other insight (as I have witnessed and felt the same kind of pain as Gianca) - iOS and Android are not aligned enough to provide a really solid customer experience but I know the Blynk team working hard in the background to get these platforms aligned ASAP and ensure parity (it feels to me that today the two platforms are dislocated and need alignment) :wink:

I have local server 0.21.5 and just updated to the very latest version of IOS today. Most projects work ok but I found some defaulted to Arduino 101 + Wifi which were setup as Wemos Mini D1; by changing it manually in IOS it lost all virtual pins and I had to re-assign manually. I should say for other projects it picked up the correct hardware profile so seemed like a bit of hit or miss.

For now I am trying to avoid logging into Android as it trashes my projects when I go back to IOS. @Dmitriy do you know when that fix will be issued for IOS ?

Guys with local servers: please pay attention to your app and server versioning. I recommend disabling apps auto-updating on your iPhone or be accurate about always updating the local server to the latest one.

Before pushing update of the app we test it agains our running server. Checking compatibility with previous server versions are beyond our possibilities.

Same for Android IMHO.

This is strange, will look into it

This is correct. The app should have told you that widgets would be reseted. Changing the device type (or deleting the device) resets assigned widgets to “no pin” state.

Thanks eugene
Perhaps you could provide as part of each iOS app (and perhaps even android) the compatible tested versions of local server ?

Btw not sure what your support is for iPad but I noticed if the tabs are on bottom row of my project it does not appear at all. Also typing in custom server IP address as part of login is not visible as iPad keyboard is rendered over input box.

@eugene btw can we now (with this new update) safely use both iOS and android with same projects ?

My understanding is that tablets, of any kind, are not supported.
Android tablets are generally fine even though they are not officially supported.
I guess “everyone” has a phone whereas that’s not the case for tablets so it seems sensible to initially support what we all have and move to other devices at a later date.

We do that already.


Where would I find the release compatability information ? - I’ve tried to search for it but I’m obviously missing something :nerd_face:

@mars latest serve always works with latest app. That’s it :slight_smile:.

@Dmitriy I have reinserted all virtual pins and now everything is working fine again :sweat: !

Ok for your suggestion to disable the App auto update because I cannot continuosly update the local server. Many project have been installed and now they are out of my control …


I thought at first that I had done the whole process of the update, but I needed to change the crontab also otherwise it would still open the old version. Afterwards all problems were solved.