Intel Edison as Blynk server

Hi guys,
just want to ask you. I want to use Intel Edison as Blynk local server, because I saw that it can be done with Raspberry Pi. Is the procedure same with Intel Edison like with Raspberry Pi?
Thanks in advance

1 Like

It’s a java based server, so if you can run the Java runtime on it, yes you can! The procedure will probably be more or less the same to set stuff up. Install java and run the server.jar :slight_smile:


@Matejic in case of success - please share with us steps “how to” so I could include it to Blynk Server documentation.

@Matejic were you able to run server?

Yesterday, I run the Blynk local server on Intel Edison and all work, Administration Panel UI work.

But I have problem with my arduino mega + esp8826. Arduino mega and esp was work on your cloud but don’t work on my server.
When I want to upload sketch on Arduino mega he show me the problem with IPAddress.

Here is my sketch that I run Blynk on Arduino Mega over ESP8266-01:

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266_HardSer.h>
#include <BlynkSimpleShieldEsp8266_HardSer.h>
#include <SimpleTimer.h>
#include <dht11.h>

dht11 DHT;
#define DHT11_PIN 12

// Set ESP8266 Serial object
#define EspSerial Serial3

ESP8266 wifi(EspSerial);

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "TOKEN";

SimpleTimer timer;

void setup()
  // Set console baud rate
  // Set ESP8266 baud rate

  Blynk.begin(auth, wifi, "SSID", "PASSWORD", IPAddress(192,168,1,8));
  timer.setInterval(3000L, sendUptime);

void loop()
{;; // Initiates SimpleTimer
  int chk; 
  chk =;

void sendUptime()
  // You can send any value at any time.
  // Please don't send more that 10 values per second.
  Blynk.virtualWrite(10, DHT.temperature,1); //virtual pin
  Blynk.virtualWrite(11, DHT.humidity,1); // virtual pin

When I upload sketch he show me the problem ‘IPAddress’ was not declared in this scope.

Can someone help me with this? :smile:


Just put “” (with quotes) in it. Lose the IPAddress part :slight_smile:


@Lichtsignaal nice, didn’t know that.

@Matejic do you have some “how to” instruction so we can share it with other users?

I will do it, but for now I must try to do that my arduino mega work with server. Will do some demonstration video with local server and intel edison but for now I must see why arduino don’t want to communicate with local server.

@Lichtsignaal I set “IPAddress(” and I upload the sketch but mega don’t communicate with local server only in console I see that Mega connected on router.
I didn’t generate self-signed certificates and I don’t know is this is needed or not. Just default setup from running jar server file

1 Like

The certificates are not needed, but you have to enter the Blynk.begin correctly, so without the IPAddress part and the ip adress between"

@Lichtsignaal I reseive in console of mega:

 [19] Blynk v0.3.3-beta
        [520] Connecting to router
        [3575] IP: +CIFSR:STAIP,""

        [3603] Connected to WiFi
        [10482] Invalid auth token
        [20912] Invalid auth token
        [31242] Invalid auth token
        [41675] Invalid auth token
        [52002] Invalid auth token
        [62434] Invalid auth token
        [72865] Invalid auth token
        [83297] Invalid auth token

I don’t know what is problem with token. Token is the same from blynk app

I found the problem with connecting on Blynk local server.
When I change the code to this
Blynk.begin(auth, wifi, “SSID”, “PASSWORD”, “”);
Mega connect on server and blynk app work with open console and connected on PC, but when I close console he disconnect from the server.
What can be te problem with this?

That is really weird. Are you sure you aren’t using double com ports or something? Are you connecting the Wifi on another com port than console? Auth token can be checked very easily, that either works or it doesn’t :wink:

@Lichtsignaal Now it’s work and don’t know what was the problem.
Thanks for helping me :wink:

1 Like