IFTTT / Amazon Echo isn't running smoothly

I’ve ran into some problems.

I can’t seem to get anything to work with my amazon echo with IFTTT.

Here is my maker stuff and the notification on alexa’s app to let me know that it was understood.

The IFTTT applet says it has ran, but my relay switch does not turn on.

Everything seems great, but why wont it work? ARRRGH!

Would appreciate some help.

Change the URL as follows:

http://blynk-cloud.com/****your blynk token/update/D1?value=0 to switch off


http://blynk-cloud.com/****your blynk token/update/D1?value=1 to switch on

Bro it works like charm for me u must be doing something wrong

Blynk url wont work instead of that u have to insert ip as i m using alexa ifttt from a long time with blynk

Small program change its
[“0”] and [“1”]
Since im using this it works for me give a try and let me know

Where do I put the [“0”] and [“1”]?

That doesn’t seem to work for me either.

It should be application json
Then in body
If you want to turn on [“0”]
Off [“1”]
Still problem ping me
This is mine

See this it works like a charm for me

Thats mine, my echo still says sending that to ifttt but still nothing happens.

If I open the blink app and check my pin, it is still pin D1 and it works perfectly from the app.

I’ve got to be missing something really stupid

EDIT: HERE/update/D1 does not work either

See iam dam sure your mistake lies in ip address u check the ip address i am 100 percent sure it would be wrong

Last thing i can suggest you make sure account you have logged in in ifttt n account in blynk both r same

I just pop into CMD and hit : ping blynk-cloud.com for a result of the same IP as I use in my IFTTT recipie.

What do you mean by that?

I’ve used the same email for both the ifttt and blynk if that’s what you’re saying.

Coming to think about it, could it have anything to do with my sketch?

#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "xxxxxx";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "ethernetwifi";
char pass[] = "passwordhere";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 8442);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8442);

void loop()


I’m using a NodeMCU ESP-12E. And my pin to toggle my relay is pin “D0”

Also, if I paste my IFTTT web request into chrome, surely it should work too right? I mean it just says “Wrong request format.”

Hey i seriously don’t know whats wrong then i gave all suggestions i could give you may be ask dimitry

Finally got it working.

I am an idiot and was using the pin out on the nodemcu and not the GPIO. How could I be so stupid…

Common mistake, if I was the manufacturer of the WeMos / nodeMCU I would swap the D references to the correct GPIO references.

Edit: just sent my formal request to Mr WeMos. Anyone know Mr / Mrs nodeMCU?

A post was split to a new topic: I can’t get my IFTTT to work