I don't manage to connect my arduino with the app

I don’t have any wifi or ethernet -shield, so i’m trying to connect them by serial usb.
I’ve downloaded the library and loaded it on arduino’s library.
I’ve done the following passages on the IDE: file—>examples---->Blink---->Boardandshields------>Arduino_Serial_usb.
Once the example has opened, i have changed the token with the same of the app, then compiled end loaded on arduino. (the sketch is attached)

I’m simply trying to switch on a single led which is connected to the digital Pin8.
I didn’t manage to start the file blynk-ser.sh from the terminal since after doing sudo ./blynk-ser.sh it doesn’t allow me writing the password, so I opened the file with textedit and changed the parameters which are highlighted with /dev/cu.usbmodem1411 as shown in arduino’s IDE.
then I opened the serial monitor and it continues showing me my token.
I’ve also tried to copying in the terminal the following words:
“telnet blynk-cloud.com 8442” and it says:
“MacBook-Pro-di-Davide:~ Davide$ telnet blynk-cloud.com 8442
Trying 45.55.195.102…
Connected to blynk-cloud.com.
Escape character is ‘^]’.
Connection closed by foreign host.”

Don’t know what to do anymore…I’m becoming crazy!
I don’t know if the things i’ve done are correct…


thank you for the help!

Hello. What do you mean by that?

when the terminal asks me to write administrator password, it doesn’t type…
here what I’ve tried to change in “blynk-ser.sh”

thank you

So what is the output of script run?

i didn’t manage to run the script from the terminal because of the problem of the password, i have only opened the “blynk-ser.sh” with text-edit and modified the parameters which i have highlighted.

Do you get some error when running without sudo?

If i drag the file to the terminal it says this (without sudo) :

This is what it does from the terminal with sudo. Maybe i’ve red that Mac doesn’t show the password on the right of the key even if you are typing for “security matters”, but also typing the correct password it shows this:

You need to be in scripts directory in order to run ./blynk-ser.sh

I’m not in the directory as I showed you? If i drag the file blynk-ser.sh in the terminal it says these:

I don’t know. You tell me. You need to “cd” to folder with script and after that run it with your “sudo ./slynk-ser.sh”

how about sudo bash ./blynk-ser.sh ?

Now it says this…what is socat? do I need to install it? :disappointed_relieved:

@Dave27 I thought ‘install socat’ had been added to the notes in the Arduino_Serial_USB example but I don’t see it.

Yes you need to install socat.

Yes, thank you, noi I have installed socat and it says this: (now I think it is a problem of my router?)

Maybe I have understood that it tries to use the port 8441 which is the SSL one? it gives problem about SSL certification. but I don’t care to use it, I can use the 8442… but is it possible to change it?

It looks like a problem with security certificates on port 8441, try tcp on 8442.

8442 should be the default as stated in blynk-ser.sh but I think you may have edited it incorrectly. Add # at the start of the lines:

SERV_PORT_SSL=8441
SERV_PORT_2WAY=8443

Actually this is a bug that is fixed already. Just get the latest version from the master branch.

But in the blynk-ser.sh file?

the latest version of what? I’ve only downloaded the library
thank you!