HOW to control Virtual pins using IFTTT

details :
• nodeMCU-12E with WIFI. For example: Arduino UNO with Ethernet Shield
• Smartphone OS Android
• Blynk server(

Simply paste your code between ``` If you don’t format your code, your topic can be deleted by moderators.

#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "WpY6CTvZ_--AUTH......";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "MARKETING";
char pass[] = "hp111414243";

  int pinValue = param.asInt(); // assigning incoming value from pin V1 to a variable
  // You can also use:
  // String i = param.asStr();
  // double d = param.asDouble();

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);

void loop()

Im using this code in my arduino the code works fine with app when i click the virtual button but when i use voice commands to control virtual pins nothing happen(voice commands are working with digital pins)

for webhooks the setting is as follows
content type:application/json
Body:[“1”] even tried blank
i have even tried the get method but nothing happens

You’re using the GET syntax with the PUT method.
Strange as it seems, you should use GET for everything, so simply change the method to GET.
The Body field should always be blank.

Your IFTTT command will only set the pins HIGH (1), so to see the change the pins already need to be set to LOW (0) by the switch widget in the app.

Also, your pinMode statements only need to run once. so should be in the void setup and the libraries used in the clde don’t seem compatible with your stated hardware (Uno plus Ethernet shield).