How to compile blynk-server source under Java8

Hi everybody
I’m trying to compile blynk-server source (0.41.2) with Maven and Java8 target
OS: Windows 10 Pro 64bit
Installed JDK 11.0.2
Maven: 3.5.3, points to JDK 11.0.2 home

I’m able to compile under Java 11 with maven from command line
mvn clean install -Dmaven.test.skip=true -Dcheckstyle.skip=true

When i try to use
source 11
target 1.8
i get the error
Fatal error compiling: warning: source release 11 requires target release 11
On the other hand when i try
source 8
target 1.8
i get the error
Compilation failure
D:/INTERNET-OF-THINGS/blynk-server/blynk-server-client-src-0.41.2/blynk-server-master/server/utils/src/main/java/module-info.java:[6,1] modules are not supported in -source 8
(use -source 9 or higher to enable modules)

So, i’m a little bit stuck

B.R
Kostas

Hello. You need to checkout source code from java8 branch. Not master branch.

Just found that I never had pushed it. Fixed.

25-13-16-27

Dear @Dmitriy
Thank You!