BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

How to change Virtual Pin Index in Blynk IoT App

In the old legacy app you had the option to choose what virtual pin index to whatever you wanted it to be. For instance I could choose V5 for a button.

Now the virtual pins you can use seems to be limited to the data type you want to use. Each button I add is assigned V0 for instance. Obviously this is a problem.

Can this be fixed/changed?

I see I can edit the datastreams in blynk.cloud, but they don’t update on the Blynk IoT app to match.

They do if you choose the correct option when you apply the changes.

Pete.

2 Likes

This is all I see for a new button on the mobile Dashboard.

Hopefully this is making sense. I also have paid for it. I’m not on a free tier.

This is what I see on the web dashboard. I’m trying to use pin V5 to match the program I wrote for and ESP32-Cam using the old Blynk mobile app. I’m not sure why it isn’t showing up in the new Blynk IoT mobile dashboard.

As I said before, I don’t think you chose the “update 1 active device(s)” option after pressing the Save button.
Make a minor change to the V5 datastream, hit save and update the active device. It should then appear as a useable datastream in the app (for widgets that use a Double data type).

Also, it’s far better if you give your datastreams sensible names…

Pete.

1 Like

@npsantini some datastreams are filtered out. For example, String datastream doesn’t work with the button, you have to use INT or Double for that.

1 Like

I think that was the problem I was having. Thanks for the help Pete!

Also, thank you @Dmitriy! That wasn’t obvious at first and will help out a lot in the future.

No problem. We’ll try to improve that, so other users wouldn’t be confused with this a well.