BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Guidance on java version for latest release 0.41.10 as earlier release like 0.41.8 had java8 version in my Ubuntu Server(with openjdk)

Hello all

Was following updates meant for blynk server but couldn’t find any particular like earlier blynk server release for java8 for current 0.41.10 like in earlier release of 0.41.8 had openjdk, kindly guide if the release 0.41.10 run with Java 8…Thanks

Just update your java version on the RPi and never worry about it again :wink:

Dear @GunnerTechTools
Java11 will not run in a tiny armv5 CPU and real world is not just RPi
plus java8 supposed to be a Long Term Support version…:slightly_smiling_face:

Java8 version is no longer needed, because there is java 11 already exists for all recent raspberries.

@GunnerTechTools & @Dmitriy Although Java 11 is available for older ARM processors, there are email certificate issues using java versions other than openjdk, but openjdk does’t run on processors below ARM7. I tried multiple releases of Java 10 and 11 on my raspberry pi zero and couldn’t email with any of them.

Is there a fix to the email issue that I’ve missed?

Thanks

Sorry to hear that… but I have absolutely NO association with Blynk development, so all I can suggest is as already above, upgrade and update, including hardware if needed.

Or somehow figure out how to generate your own Java8 version from the server source code… and sorry, I have no idea how to do that :stuck_out_tongue:

Hi Dmitriy,

This below section needs to be updated then,

Regards,
Gaurav Barwalia

No complains at all, just notice.
Open software developers have their own targets and priorities.
As you said, if you need something different, you have to take action on your own…
Fair!