BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Google Assist+ IFTTT+Blynk

#1


Hello everyone, I'm trying, via Google Assist and IFTTT, to connect to my module esp8266-12f. I have refactored IFTTT programming several times and when I call Google and say the programmed command, Google opens a search page and does not activate anything, providing the following information (it looks like these lights have not yet been configured). Can someone help me?

0 Likes

#2

Sounds like Google Assistant account isn’t linked to your IFTTT account. Try un-linking and re-linking.

Also, you’d be better using GET rather than PUT and putting the whole API command in the URL field and nothing in the Body field.

The GET syntax is slightly different though.

Pete.

0 Likes

#3

Try unlinking and re-linking, I already did and it did not work.

0 Likes

#4

Also, it would be better to use GET instead of PUT and put the whole API command in the URL field and nothing in the Body field, I already did this and it did not work.

0 Likes

#5

I already changed it to https: //, and it still did not work.

0 Likes

#6

Google

0 Likes

#7

Can anyone help me with this?

0 Likes

#8

Please help me

0 Likes

#9

https://blynkapi.docs.apiary.io/#reference/0/write-pin-value-via-get/write-pin-value-via-get?console=1

Make sure your auth code is correct. Try the URL in your web browser to be sure it is working.

0 Likes

#10

I think you need to remove the code from the “body” part of the IFTTT function and the url should look like this:

http://45.55.96.146/a9xxxxxxxxxxxxd0/update/V3?value=1

http://45.55.96.146/a9xxxxxxxxxxxxd0/update/V3?value=0

As @PeteKnight has already said, use GET instead of PUT.

Is that IP address correct for you? - Make sure it is, otherwise it will not work.

0 Likes

#11

The URL is normal, through the Google Assistant that is broadcasting this message.

0 Likes

#12

I’ve already switched to GET too, and that did not help.

0 Likes

#13

What does this message mean in English?

Please post your latest IFTTT recipe, and details of exactly what happens when you use the same URL in a browser.

Pete.

1 Like

#14

when I ask Google to turn on lights, it responds to this message:
it looks like these lights have not been set up config

0 Likes

#15

and when I type Url on Google, it performs the normal command.

0 Likes

#16

0 Likes

#17

I don’t think it’s a Blynk issue.
Maybe a question for the IFTTT or Google Assistant user forums?

Pete.

0 Likes

#18

I posted some conversations in the Google Forum Assist, so far I have not received an answer, I’m really looking forward to it.

0 Likes

#19

It may have something to do with your verbal/written commands.

The first one has a typo. “ligths” instead of “lights”. Also the verbal command would be, “Hey/OK Google, Lights on” or “Hey/OK Google, on lights”. Saying “Hey Google, Turn on Lights” may cause an error. Either add “turn” to the written command line, or don’t include it in the verbal command.

1 Like

#20

I need url to connect my blink to google assistant, may i know the steps to get a url

0 Likes