First line of lcd text disappears


I’m sorry if this has been addressed before. I tried to find it in the forum but didn’t see anything. My 3 lcds work but if leave the app for too long or quit the app and come back (I have iPhone) the first line of text disappears while the second line stays. Theyre connected to virtual buttons and the first line comes back when it is called. Is there a way to either make both lines disappear or stop the first line from disappearing?


Hello. Do you use latest Blynk app? Are you sure your code doesn’t erase first line?

I just updated the app and now nothing shows up on my LCDs at all :confused: any suggestions? @Dmitriy

Could you please post your code? I think we need to start looking for clues there :slight_smile:

Unfortunately, I lost my code in a hard drive incident. I don’t think it’s my code though since it worked before the update and I haven’t changed anything

Well, that’s crap in any case! I hate it when that happens to me.

Anyway, Blynk App is continuously updated so it can be a problem with your code in combination with the app or just the app, either way, I still think it’s pretty much not traceable because we are missing a piece of the puzzle. Just because something stops working doesn’t mean it’s not a fault of something that is made earlier. These systems all interact and weird stuff can happen unfortunately.

I think you are better off writing some new code and see what happens.

Ok, I’ll give that a try

I just hope it’s not too much work for you :wink:

I remember a crash several years ago, it still bugs me, lol.

Thanks lol. I backed it up a few months ago so I didn’t lose everything. The problem is that the project is attached to something at my parents house so I don’t have access to the arduinos in question. Next time I go home I’ll try to get it working again and figure out what the problem is