Failed to disable echo...esp8266-01

i am using arduino uno …
esp8266 worked fine for few days now its saying failed to disable echo

[UPD: “Failed to disable echo” will most probably be reported as “ESP is not responding” now]

Let me check my crystal ball… :wink:

Unfortunenately my crystal ball is broken. Can you provide some more information? How are things hooked up (especially in the power department). The solution of an ESP as a shield on the Arduino is notoriously instable if you the connections are a little off.

Also, what code are you using? (properly formatted, three backticks before and after the code please).

1 Like

vcc and ch_pd to 3.3v
gng–gnd
tx-2
rx-3

this is my code…

#define BLYNK_PRINT Serial    
#include <ESP8266_Lib.h>
#include <BlynkSimpleShieldEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "ff1abd13a2424ffa942592182d84ec23";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "divya";
char pass[] = "andendivs"; //uprv1234bsnl sakthi0054
#define LM1 10     // left motor
#define LM2 11      // left motor
#define RM1 8      // right motor
#define RM2 9    
#define trigPin 13
#define echoPin 12

// Hardware Serial on Mega, Leonardo, Micro...
//#define EspSerial Serial1

// or Software Serial on Uno, Nano...
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(2, 3); // RX, TX

// Your ESP8266 baud rate:
#define ESP8266_BAUD 9600

ESP8266 wifi(&EspSerial);

void forward()
{
 digitalWrite(LM1, LOW);
    digitalWrite(LM2, HIGH);
    digitalWrite(RM1, HIGH);
    digitalWrite(RM2, LOW);
}
void backward()
{
  digitalWrite(LM1, LOW);
    digitalWrite(LM2, HIGH);
    digitalWrite(RM1, LOW);
    digitalWrite(RM2, HIGH);
    
}
void right()
{
  digitalWrite(LM1, LOW);
    digitalWrite(LM2, HIGH);
    digitalWrite(RM1, LOW);
    digitalWrite(RM2, LOW);
   
}
void left()
{
  digitalWrite(LM1, LOW);  //left
    digitalWrite(LM2, LOW);
    digitalWrite(RM1, HIGH);
    digitalWrite(RM2, LOW);
    
}
void Stop()
{
  digitalWrite(LM1, LOW);
    digitalWrite(LM2, LOW);
    digitalWrite(RM1, LOW);
    digitalWrite(RM2, LOW);
  
}
void setup()
{
  // Set console baud rate
  Serial.begin(9600);
  pinMode(13,LOW);

  
  pinMode(trigPin, OUTPUT);
  pinMode(echoPin, INPUT);
  pinMode(LM1, OUTPUT);
  pinMode(LM2, OUTPUT);
  pinMode(RM1, OUTPUT);
  pinMode(RM2, OUTPUT);
  delay(10);
  // Set ESP8266 baud rate
  EspSerial.begin(ESP8266_BAUD);
  delay(10);

  Blynk.begin(auth, wifi, ssid, pass);
}
BLYNK_WRITE(V1) 
{
  int x = param[0].asInt();
  int y = param[1].asInt();
  if(y>220)
  forward();

 else if(y<35)
 backward();
  else if(x>220)
right();
  else if(x<35)
left();
  else
Stop();

}
void loop()
{
  Blynk.run();

 
  
}`Preformatted text`

Have you tried searching this forum for that error message?

That one didn’t help me… I already tried it too… That is why I started a new thread

That “one”?? There are over 50 threads shown at a time with this error message… many with solutions.

What happened in between it working and not working, app update, code modification, etc… what else have you tried so far?

I didn’t modify anything… This module is very unstable…i have no idea what went wrong…

Start back at the basics then… load in a simple demo sketch.

http://examples.blynk.cc/?board=Arduino%20Uno&shield=ESP8266%20WiFi%20Shield&example=GettingStarted%2FBlynkBlink

I got the same error…
I tried this basic code with uno… It’s still showing ‘failed to disable echo’

Well, this is a well known issue with ESP shields, and not a Blynk specific issue that I can tell.

And scanning through the posts, I can see that there can be a few different things that cause that message… but sorry, I am not going to read through every previously posted thread, and troubleshoot each step for you.

Read, learn, make notes, and test… if after a few hours or days you are still in a bind, then let us know what you have tried so we can better narrow the issue down.

As your posted sketch implies a moving object, I would start by looking at power issues and loose connections between the shield and Uno.

I read all the threads of which only two helped me…
1.to update the firmware(idk how to do it… I’m new to this platform can somebody help?)
2. To run the bare minimum sketch and test it(i tried it but it’s not responding to my at commands in both 9600 and 115200 baud rates)
Pls help me… :see_no_evil:i have a competition tomorrow

Idea, do you have a resistor from Tx Arduino to Rx ESP? If not, the Arduino has 5v logic. You may have blown the Rx line on your ESP. This process van be very slow and may run for a certain time, but in the end the Logic level of 3.3v from the ESP cannot handle the Tx 5v from the Arduino.

1 Like

I don’t have any resistor btw esp rx and arduino tx…
I directly connected it to pin 3 of the arduino

Anyone???

Borrow an ESP with an onboard USB for your competition.

Like esp8266 12E?? Should i try it in standalone??

Standalone is much easier than the shield method. I was thinking of the Blynk board, WeMos or nodeMCU with the USB port as they are plug and play rather than toil and pray with the shield method.

The same problem with you. I’ve already found and tried a lot of tutorial and solved problem in google but i can’t fix it. I think the problem is the wrong baudrate to esp8266 because it didn’t respond AT when i type AT command, but when i reflash the firmware to esp8266, nothing still change. I’ve tried to flash many firmware, many AT SDK .bin files, and the problem haven’t been solved now. So obstructive!

Different firmwares can have different baud rates!

Guys… Is it possible to connect Nodemcu with arduino uno?