Exit status 1 Error compiling for board NodeMCU 1.0 (ESP-12E Module)

Hello everybody,

Sorry I’m a new person who trying use blynk witn nodemcu board.

I installed the newest version libraries according instruction

I received following error:

compilation terminated.

Using library ESP8266WiFi at version 1.0 in folder: C:\Users\Andrzej\Documents\ArduinoData\packages\esp8266\hardware\esp8266\2.3.0-rc2\libraries\ESP8266WiFi 
Using library Blynk at version 0.5.4 in folder: C:\Users\Andrzej\Documents\Arduino\libraries\Blynk 
exit status 1
Error compiling for board NodeMCU 1.0 (ESP-12E Module).

Could you help me

Thanks in advance

To start off with… you need a much newer ESP Core for Arduino… latest is 2.4.2

1 Like

I changed to ESP Core for Arduino… latest is 2.4.2

and now I have :

Arduino: 1.8.7 (Windows Store (Windows 10), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, 4M (1M SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.15.0_x86__mdqgnx93n4wtt\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.15.0_x86__mdqgnx93n4wtt\hardware -hardware C:\Users\Andrzej\Documents\ArduinoData\packages -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.15.0_x86__mdqgnx93n4wtt\tools-builder -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.15.0_x86__mdqgnx93n4wtt\hardware\tools\avr -tools C:\Users\Andrzej\Documents\ArduinoData\packages -built-in-libraries C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.15.0_x86__mdqgnx93n4wtt\libraries -libraries C:\Users\Andrzej\Documents\Arduino\libraries -fqbn=esp8266:esp8266:nodemcuv2:CpuFrequency=80,VTable=flash,FlashSize=4M1M,LwIPVariant=v2mss536,Debug=Disabled,DebugLevel=None____,FlashErase=none,UploadSpeed=115200 -ide-version=10807 -build-path C:\Users\Andrzej\AppData\Local\Temp\arduino_build_130451 -warnings=none -build-cache C:\Users\Andrzej\AppData\Local\Temp\arduino_cache_603760 -prefs=build.warn_data_percentage=75\Users\Andrzej\Documents\ArduinoData\packages\esp8266\tools\esptool\0.4.13\Users\Andrzej\Documents\ArduinoData\packages\esp8266\tools\esptool\0.4.13\Users\Andrzej\Documents\ArduinoData\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\Users\Andrzej\Documents\ArduinoData\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\Users\Andrzej\Documents\ArduinoData\packages\esp8266\tools\mkspiffs\0.2.0\Users\Andrzej\Documents\ArduinoData\packages\esp8266\tools\mkspiffs\0.2.0 -verbose C:\Users\Andrzej\Documents\Arduino\libraries\Blynk\examples\Boards_WiFi\NodeMCU\NodeMCU.ino

Board nodemcuv2 (platform esp8266, package esp8266) is unknown

Error compiling for board NodeMCU 1.0 (ESP-12E Module).

Hard to say… could be a syntax error in your code… which is??

And please format it properly as required in the Welcome Topic :wink: (as I just did for your last post)


You could also Google your error… perhaps you need to do a clean install of something?

#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "YourNetworkName";
char pass[] = "YourPassword";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);

void loop()

I triedd do proper but I don’t know how it works

If I did wrong, please forgive me

There must be something wrong with the installation of the IDE (I guess you use windows app) and the core for the ESP.

Board nodemcuv2 (platform esp8266, package esp8266) is unknown

I’d suggest using the “Windows ZIP file for non admin install” version of the IDE. Never had such kind of problems with that variant.

Your source code compiles with no errors in my set-up.

1 Like

I triedd but without effect.

It is possibe to connect with you via Timeviewer .Mayby i do something wrong with configuration ?

I would be grateful

@Andrew1 Just uninstall the current IDE and all related files and start from scratch with the
latest “Windows ZIP file for non admin install”.

A post was split to a new topic: Error when compiling sketch