BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Event+timer

I have little problem. In my project, to control the relay in the widgets the button and timer use digital outputs. In this case, the system works fine. But I would like to receive a message about turning the relay on and off by email. To do this, I use the eventor widget and virtual pin V0. Event1: “When V0 is equal to 1 -turn ON gp12 - send email…”, Event2: “When V0 is not equal to 1 -turn OFF gp12 - send email…” I look at the value of this virtual pin V0 in the value display widget.
I start the blink player. I press the button, everything works fine. When the timer starts, 1 appears in the virtual pin V0 =1, but the digital output does not accept a high value, the relay does not work, and an e-mail message is not sent. Why?

I have iOS so I haven’t used the eventor. However for testing have you tried emailing from your code?

Emailing is not a problem. Emailing work ok with eventor too. Problem is that when V0 activated by pushbutton, eventor send email, but when V0 activated by timer, eventor do nothing.

@daveblynk and I are iOS users and we don’t really see the benefit of Eventor. I suspect that the same would be true if we were Android users too, as its a bit of a “mickey mouse” alternative to doing it the correct way - in code.

I guess that if you shared some screenshots of you Eventor setup the some Android users may be able to point you in the right direction, but its unlikely that they’d be able to advice based on just the information you’ve provided so far.

Pete.

1 Like

That is what I mean. In the code trigged by the timer put the email trigger and tell me if it works…

In the code everything work good. There I don’t have problem.

So we can mark this as “Solved” then?

Pete.


I’m very familiar with doing it correct way, but situation is that I have not atcess to ESP8266. I downloaded basic blynk code for basic control and send to person for control just over button. Now we have idea realize extra function, without sending the device to me for reprogramming.
Beside. It is possible to make timer in eventor and then it work ok too, but the problem that time in eventor could be changed only in stop mode. When I share application, the user can’t stop app and could not change time himself.

Grabbing at straws here… did you try event 1 equal to 0 and event 2 equal to 1? Just to see if it is the high/low call that is the issue. Or event 2. Or maybe add a 3rd event… Just troubleshooting…

Time to install HTTP OTA then🙂

Pete.

This is an option in future,

image
Call sequence I have tried. This could not be the issue, because when I push the button with V0 eventor work correct. When Timer change V0 eventor doesn’t work.