ESP8266 with AT firmware

I have been able to set up my esp8266-01 as a standalone unit and switch on and off over the net
I have followed Volodymyr tutorial on ESP8266 with AT firmware but I am getting nowhere

I have changed the baudrate but each time I upload the sketch

I have been unable to try and find answers on the internet but so far I have been able to find any answers

i get the following error message

Multiple libraries were found for "BlynkSimpleShieldEsp8266.h"
 Used: C:\Users\John\Documents\Arduino\libraries\Blynk
 Not used: C:\Program Files (x86)\Arduino\libraries\Blynk
 Not used: C:\Program Files (x86)\Arduino\libraries\Blynk
 Not used: C:\Program Files (x86)\Arduino\libraries\Blynk
 Not used: C:\Program Files (x86)\Arduino\libraries\Blynk
exit status 1
Error compiling for board Generic ESP8266 Module.

Any help appreciated

Your Serial Monitor shows conflicting issues… you can’t use the shield library with ESP as standalone

These are both totally different from each other… you can use the ESP with the AT command firmware as a WiFi-Serial adapter (then you use the shield library, but use the Arduino board in the IDE)… OR load in the ESP/Arduino firmware and run it as a standalone device (then you use both the ESP libraries and board in the IDE), but not both at the same time… Each use different library, IDE & sketch approaches.

http://help.blynk.cc/how-to-connect-different-hardware-with-blynk/arduino/esp8266-standalone

http://help.blynk.cc/how-to-connect-different-hardware-with-blynk/arduino/esp8266-with-at-firmware

Thanks Gunner
I have tried connecting again my Arduino Uno and ESP8266-01

Am I getting there with a WiFi connection I have removed my SSID & Password before I uploaded the screen shot
Is there any application in Blynk that I can use to see if I am online
When I went to sketch builder and clicked on the Nano board the only connection type available was the ethernet ENC28J60
I tried instead of using the uno board and esp8266-01 the sketch uploaded but still no luck
I also changed the pins from TX and RX on the nano board to pins D2 and D3 as I noticed in the sketch for software serial 2 and 3

Thanks oldvolt

I don’t know why the Sketch builder is that way… the Nano is basicly the same as the UNO, just different packaging.

However, based on your screenshot, it looks like it connected OK… not quite sure if it stayed connected or not as the screen shot didn’t go that far down (don’t you hate it when you try to scroll down a window in a full desktop image :blush: ) .

Well, the App itself should show if the device is connected or not… just click on the little ‘chip’ icon to confirm.

52