esp8266 standalone and local server - cant connect


This is my first attempt to use an ESP8266. I have the ESP-12E module and have successfully loaded the Standalone example sketch on to it. I can see it is a client on my local wifi router but it does not seem to connect to the Blynk local server that I have running on a Raspberry Pi.

The arduino IDE serial monitor shows "Connecting to Palmbye’ (Note- Palmbye is the name of my local network) but that is all that happens. I have the correct token that is generated by my local server in the sketch and I do this for starting Blynk in the sketch—>

The Blynk App on my IOS device just saysESP8266 is offline

Any ideas on what I am missing, I have searched for several hours but am at a dead end right now. Any help would be greatly appreciated.

Hello. Was you able to connect to Blynk cloud with your ESP?

I have not tried connecting to the Blynk Cloud. Could it be a problem with my local server not supporting the ESP?
I have not updated my local server for a few months

U[quote=“NickMurray, post:3, topic:3833”]
I have not tried connecting to the Blynk Cloud. Could it be a problem with my local server not supporting the ESP?

Well. It shouldn’t, but it could be. I can’t give you exactly answer as I never run old versions of servers with new Apps and new libraries.

Sure, That’s fair enough. To be honest I have been putting off updating the Local server because I am unsure about how to go about it. I have existing projects running on my current local server that I would like to keep. Is there any instruction on how to update the local server without losing currently running projects?

edit---- I see there is a some information on it here

Usually when you go from one update to another your projects will be fine. For now we you have 2 options :

  • Do not update apps, libs, server and keep everything as it is;
  • Update server, apps, libs every time or once a 1 month for instance;

In general you may need update only if you see some interesting feature and want to try it.

Just an update before I go ahead and try my first Local Server Update. My original problem of getting the ESP8266 to connect has been resolved. I tried using a different WiFi router and it connected perfectly. So there was no issue with the Sketch or the outdated local server. My problem must have something to do with the Wifi network that I was trying to connect to.

This thread can be closed now. ill post to a more relevant thread regarding my local server update.

Try changing this too:


Hi @Lichtsignaal I changed the sketch as you suggested but it works the same. I guess either format for the IP address is ok. Your way does look neater so I will run with it that way.

So I still have the same issue; I can connect to my local network with one router but not with another. I must have something set up differently in one of the routers. Ill keep digging to try and figure it out.

Another question… Is it possible to set a fixed IP address in the esp8266?

On the same problem trying to connect an esp8266 to a local Wi-Fi router. Note I can connect to one router but not another. I only have the router that doesn’t work with me at the moment so I cant check the settings on the router that does work.

Does it matter which type of Security is set up on the router? WPA or WPA2 or WPAMixed

Then there is another selection called pre-shared key format? Hex or Passphrase

PSK equals WPA/WPA2-PSK. Anything other, like WPA2-Enterprise is username/password, which is not supported (I think), but most home routers with just a Key work fine with the ESP so all in all, that should work.

If you are connecting to the cloud, it could be the source nat goes wrong, long technical stuff, but can you tell me the brand/type router which doesn’t work, or are they the same? Also, do you connect you ESP to the cloud Blynk or a local server?

Yes, you can set a manual IP in the ESP, just like you can with Ethernet. I think the Ethernet_Manual example has info on that, you can replicate that to your ESP sketch just fine.