ESP8266 (D1 Mini) Appearing Offline

Hello!
I made this project where the MIDI from my piano gets sent to a LED strip (so that it’ll light up at the corresponding key) via a D1 Mini connected to my PC, and made it so that I can change the colour of the LEDs in Blynk. It worked fine up until I had to send my PC away for repairs. When it got back, I tried using it again, yet it would appear offline in Blynk. I’ve rewritten the code, I tried resetting the auth code, downloaded all the programs to transfer the MIDI again, but nothing fixes it and I can’t find anything online.
The MIDI itself gets transferred to the board fine, but its problem probably lies with the connection to Blynk itself, which is kind of required for it to work because of it not having an assigned colour without it.

Info:
D1 Mini V2, Arduino IDE
iOS 15.1.1
Blynk Server
Blynk Library Version 1.0.1

#define BLYNK_PRINT Serial
#include <BlynkSimpleEsp8266.h>
#include <MIDI.h> 
#include <Adafruit_NeoPixel.h>
#define PIN D6
#define NUM_LEDS 213 
Adafruit_NeoPixel strip = Adafruit_NeoPixel(NUM_LEDS, PIN, NEO_GRB+NEO_KHZ800);

MIDI_CREATE_DEFAULT_INSTANCE();
char auth[] = "[code]"; //auth code
char ssid[] = "[ssid]"; //wifi ssid
char pass[] = "[pass]"; // wifi pass
int r,g,b;
void setup() {
  
  strip.begin(); 
  strip.show();
  strip.setBrightness(200);
  MIDI.begin(MIDI_CHANNEL_OMNI);
  MIDI.turnThruOff();
  Serial.begin(115200);  
  Blynk.begin(auth,ssid,pass);
  MIDI.setHandleNoteOn(MyHandleNoteOn); 
  MIDI.setHandleNoteOff(MyHandleNoteOff); 
}

void loop() { 
  MIDI.read(); 
  Blynk.run();
}

BLYNK_WRITE(V3)
{
  r = param[0].asInt();
  g = param[1].asInt();
  b = param[2].asInt();

}

void MyHandleNoteOn(byte channel, byte pitch, byte velocity) {
    int y = pitch*2;
    int x=y+1;
    strip.setPixelColor(y-4, r, g, b); 
    strip.setPixelColor(x-4, r, g, b); 
    
    strip.show();

  }

void MyHandleNoteOff(byte channel, byte pitch, byte velocity) {
      int y = pitch*2;
      int x=y+1;
      strip.setPixelColor(y-4, 0, 0, 0);
      strip.setPixelColor(x-4, 0, 0, 0);
      strip.show();
  }

What do you see in the serial monitor?

Pete.

Currently nothing, though I might be doing something wrong (didn’t write the code myself, which I forgot to mention. I also don’t know much about Arduino)

Blynk legacy or IOT ?

I’d suggest that you work on getting the serial monitor to show something.
Ensure that you have the correct COM port selected and the baud rate.
If you’re still not seeing any output then try disconnecting everything from the Wemos (apart from the USB cable) and seeing if that helps.

Pete.

The older one, so I assume IOT

When having the hairlessmidiserial program open, the COM becomes busy and I’m not able to open the serial monitor. And when having the program closed, nothing shows up in the serial monitor. Also, is the baud rate supposed to be equal to the upload speed or does that not matter?

That sounds like you have a COM port conflict. I’d try using just the Wemos on its own to begin with.

The two are totally independent.
Personally, I’d change this line:

to:

Serial.begin(74880);

as that is the default baud rate of the D1 Mini and using that baud rate will allow you to see the boot output from the Wemos as well as the debug output from your sketch when you set the serial monitor to 74880.

Pete.