Esp8226 Shield does not work with Local server

Hello ,

I`m trying to connect blynk with ESP8226 01 with local server

device - Ardunio mini MEGA , ESP8226 01 Shield (ATcommand)
connection type - wifi
local server (running in google cloud)

My problem is that I do not know how to set IP of local server into ESP or Blynk.begin function . When I run my program with default Blynk cloud my connection is perfect .
But I can not crate connection with local server .

I tryed calling Blynk.begin function like :

Blynk.begin(auth, wifi, ssid, pass, "");


Blynk.begin(auth, wifi, ssid, pass, "",9443);


char server [] = "";
Blynk.begin(auth, wifi, ssid, pass, server);


char server [] = "";
char port[]="9443";
Blynk.begin(auth, wifi, ssid, pass, server, port);

I tryed also to change β€œ.” to β€œ,” but did not help.

My local server should be fine becouse I can connect to it with phone and manage it via admin settings in google.

My project is long and it is not in english so I will post example that I used to connect with Blynk , the example is in library Blynk\examples\Boards_WiFi\ESP8266_Shield

#include <ESP8266_Lib.h>
#include <BlynkSimpleShieldEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "YourNetworkName";
char pass[] = "YourPassword";

// Hardware Serial on Mega, Leonardo, Micro...
#define EspSerial Serial1

// or Software Serial on Uno, Nano...
//#include <SoftwareSerial.h>
//SoftwareSerial EspSerial(2, 3); // RX, TX

// Your ESP8266 baud rate:
#define ESP8266_BAUD 115200

ESP8266 wifi(&EspSerial);

void setup()
  // Debug console


  // Set ESP8266 baud rate

  Blynk.begin(auth, wifi, ssid, pass);

void loop()

My output in Serial console look like this :

    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.6.1 on Arduino Mega

[3771] Connecting to MyWifi
[6816] AT version: 14 2016 18:54:01)
SDK version:2.0.0(656edbf)
compile time:Jul 19 2016 18:44:44
[13929] +CIFSR:STAIP,"myIP"
[13938] Connected to WiFi

Program stopps after " [13938] Connected to WiFi"

Thank you for reply or reading . If this problem was already discoused or solved somewehere I m realy sorry for reposting it again , I tryed to find solution before postin but with no success thank you .

Just because you can do this doesn’t mean that the port you are trying to use for the hardware to server connection is open, forwarded to your local server, and correctly set-up with an encryption certificate.

The app and management console use different ports to the hardware.


Hello , Thank you for advice .

It was my stupid . I did not allow port:8080 in firewall server settings. now everything works fine . Thank you .

1 Like