Error with compiling (Blocked COM Port)

Hi, I have been using Blynk for only a few hours and I keep having this error when I compile:
avrdude: ser_open(): can’t open device “\.\COM3”: Access is denied.

My Arduino is an Uno and is connected through COM3. I want to use Blynk through USB because I don’t have an Ethernet Shield. I have also tried the Arduino Example Blink for an LED and that has the same error.

Please ask me if you need more info.



/* Comment this out to disable prints and save space */
#define BLYNK_PRINT SwSerial

#include <SoftwareSerial.h>
SoftwareSerial SwSerial(10, 11); // RX, TX
#include <BlynkSimpleStream.h>
#include <DHT.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "d2733e23ceb443d2ac964b1ad7abed56";

#define DHTPIN 2          // What digital pin we're connected to

// Uncomment whatever type you're using!
#define DHTTYPE DHT11     // DHT 11
//#define DHTTYPE DHT22   // DHT 22, AM2302, AM2321
//#define DHTTYPE DHT21   // DHT 21, AM2301

BlynkTimer timer;

// This function sends Arduino's up time every second to Virtual Pin (5).
// In the app, Widget's reading frequency should be set to PUSH. This means
// that you define how often to send data to Blynk App.
void sendSensor()
  float h = dht.readHumidity();
  float t = dht.readTemperature(); // or dht.readTemperature(true) for Fahrenheit

  if (isnan(h) || isnan(t)) {
    SwSerial.println("Failed to read from DHT sensor!");
  // You can send any value at any time.
  // Please don't send more that 10 values per second.
  Blynk.virtualWrite(V5, h);
  Blynk.virtualWrite(V6, t);

void setup()
  // Debug console

  // Blynk will work through Serial
  // Do not read or write this serial manually in your sketch
  Blynk.begin(Serial, auth);


  // Setup a function to be called every second
  timer.setInterval(1000L, sendSensor);

void loop()

GOOGLEing that error would show that something else is using COM3 at the time you are trying to run the USB script or program the Arduino… make sure you do NOT have the Arduino IDE’s Serial Monitor also running.

1 Like

I don’t

Well your error is Arduino IDE related, not Blynk… so as suggested, Google avrdude: ser_open(): can’t open device and Access is denied and step through the various checks and solutions.

Try running Arduino as Administrator. Since it needs to run a script to get Serial connection, it needs to have enough rights.

Check the programmer below tool bar and change it to none

A post was split to a new topic: Access Denied issue