BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Error starting Blynk server. Stopping


#1

Hi,
I tried to start the Blynk-Server on my Server but only get this:

root@localhost:~# java -jar server-0.41.1.jar -dataFolder /home/blynk &
[3] 764
root@localhost:~# WARNING: sun.reflect.Reflection.getCallerClass is not supported. This will impact performance.
Error starting Blynk server. Stopping.

My java version is:

root@localhost:~# java -version
java version “11.0.1” 2018-10-16 LTS
Java™ SE Runtime Environment 18.9 (build 11.0.1+13-LTS)
Java HotSpot™ 64-Bit Server VM 18.9 (build 11.0.1+13-LTS, mixed mode)

My Server:

root@localhost:~# cat /etc/os-release
PRETTY_NAME=“Debian GNU/Linux 9 (stretch)”
NAME=“Debian GNU/Linux”
VERSION_ID=“9”
VERSION=“9 (stretch)”
ID=debian

I also tried to use several releases but got the same error everytime:
server-0.41.1-java8.jar
server-0.41.1.jar
server-0.41.0-java8.jar
server-0.41.0.jar

Does anyone has any suggestions?
Thank you!


#2

Hello. Do you see some errors in the blynk.log file? Most probably you have busy ports.


#3

There is no blynk.log file.

root@localhost:/home/blynk# ls -la
total 20
drwxr-xr-x 5 root root 4096 Jan 7 22:41 .
drwxr-xr-x 3 root root 4096 Jan 7 22:40 …
drwxr-xr-x 2 root root 4096 Jan 7 22:41 backup
drwxr-xr-x 2 root root 4096 Jan 7 22:41 clone
drwxr-xr-x 2 root root 4096 Jan 7 22:41 deleted

I also looked in /var/log/, but there is also no blynk.log


#4

Hi, I have same problem and solved it, by using change the folder name from blynk to Blynk. I hope benefit for you.


#5

Wow, hard to believe, but that actually solved the problem. :smile:
Thank you so much!