Error flashing for board NodeMCU 1.0

Can’t load test case from Blynk library called NodeMCU. Other simple sketches, e.g. blink, load well.
Blynk 0.6.1, 1.0.0-beta.3 is tested also.

Arduino: 1.8.13 (Windows 10), Плата:“NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), 4MB (FS:2MB OTA:~1019KB), 2, v2 Lower Memory, Disabled, None, Only Sketch, 115200”
Executable segment sizes:

IROM   : 247892          - code in flash         (default or ICACHE_FLASH_ATTR) 

IRAM   : 27928   / 32768 - code in IRAM          (ICACHE_RAM_ATTR, ISRs...) 

DATA   : 1300  )         - initialized variables (global, static) in RAM/HEAP 

RODATA : 2236  ) / 81920 - constants             (global, static) in RAM/HEAP 

BSS    : 25544 )         - zeroed variables      (global, static) in RAM/HEAP 

Скетч использует 279356 байт (26%) памяти устройства. Всего доступно 1044464 байт.

Глобальные переменные используют 29080 байт (35%) динамической памяти, оставляя 52840 байт для локальных переменных. Максимум: 81920 байт. v2.8

Serial port COM3

Traceback (most recent call last):

  File "C:\Users\Usserr\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.7.4/tools/", line 65, in <module>


  File "C:/Users/Usserr/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\", line 2889, in main

    esp = chip_class(each_port, initial_baud, args.trace)

  File "C:/Users/Usserr/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\", line 237, in __init__

    self._port = serial.serial_for_url(port)

  File "C:/Users/Usserr/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.4/tools/pyserial\serial\", line 88, in serial_for_url

  File "C:/Users/Usserr/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.4/tools/pyserial\serial\", line 62, in open

    raise SerialException("could not open port {!r}: {!r}".format(self.portstr, ctypes.WinError()))

serial.serialutil.SerialException: could not open port 'COM3': OSError(22, '������� �������������� ����������.', None, 433)

serial.serialutil.SerialException: could not open port 'COM3': OSError(22, '������� �������������� ����������.', None, 433)


#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "YourNetworkName";
char pass[] = "YourPassword";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);

void loop()

Try rebooting your PC and check that the COM port selected in the IDE is still valid then try uploading again.


Thank you. I tried all this many times. These reasons are clearly not the problem. Other sketches with other libraries loads fine. I believe that the error "could not open port ‘COM3’ " occurs after the failed load of this sketch.

In that case, it would have been useful if you said “I’ve tried X, Y & Z” in your original post.

This isn’t a Blynk issue.
If you have access to another NodeMCU, or another computer where you can install the Arduino IDE, ESP core and libraries then that may enable you to get to the bottom of the problem.


I wrote in the first post that loading other sketches works well. If all other sketches are loading, but the blynk does not load, it is logical to assume that the problem is in the blynk or in the ESP8266WiFi.h. But it may not be so.
I was hoping you could tell me.

All of the error messages you posted relate to the ESP core version 2.7.4 and there’s no mention of issues with the Blynk library.
The errors with the .py files are all associated with the file upload process and are the sort of issues you see when there is a problem finding or opening the chosen COM port.


I assume that you have up to date libraries. I know this is obvious but did you check you can see the com port in the tools menu. The reason I say this is because I often have to disconnect the USB close down Arduino IDE and restart the IDE. This is often required when having more than one sketch up. The IDE seems to remember that the port was in use by a sketch and will not connect to another sketch.

Thank you. Of course, I checked everything you say. This is the first time I come across that due to problems with the library (ESP8266WiFi.h ? ), the sketch cannot even load.

It’s not a problem with any of your libraries. If it was, you’d see compiler errors or crashes once the code was uploaded.

As I’ve said before, it’s a problem with the upload process and/or the COM port being used, or with the ESP board.

Have you tried pressing the RST button on the board and keeping it pressed while you’re applying power to the board, then releasing it and trying the upload again?


When you upload the file, after it compiles and it shows it trying to connect to the device, puss the flash button on MCU