BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Encountering issue with robotdyn UNO r3 + esp8266

Greetings,

I have arduino:
uno-wifi-r3-atmega328p-esp8266-32mb-flash-usb-ttl-ch3, robotdyn’s product.
I wish to program it’s ESP8266 to work with blynk and to communicate with the arduino.

So I programmed ESP8266, by turning switches 5, 7 and 7 to ON and uploading this code:

        #define BLYNK_PRINT Serial


    #include <ESP8266WiFi.h>
    #include <BlynkSimpleEsp8266.h>

    // You should get Auth Token in the Blynk App.
    // Go to the Project Settings (nut icon).
    char auth[] = "Actual Token";

    // Your WiFi credentials.
    // Set password to "" for open networks.
    char ssid[] = "myActualWifiSSID";
    char pass[] = "12345678";

    void setup()
    {
      // Debug console
      Serial.begin(115200);

      Blynk.begin(auth, ssid, pass);
    }

    void loop()
    {
      Blynk.run();
    }

And left my arduino code empty (after uploading the code with 3, 4 switches on ON).
I have then turned switches 1 and 2 to ON and resetted both ESP and arduino. I also previously made a project on blynk app to control ARDUINO UNO with it and made a button switch for pin D13 to turn off and on on press, but this doesn’t seems to work. I know that the ESP connected to my wifi, because I can see it on the list of connected devices. The blynk app also says it’s connected, but the button doesn’t’ seems to control the arduino itself. I was hoping someone could tell me why, I am new to this.

Id’ say that the blynk library is: Blynk_Release_v0.6.1
The board I use in Arduino IDE to insert code to ESP8266 is Generic ESP8266 Module

I’m sorry if I have missed out some detail while writing this post, I will be sure to add it afterwards.

Thanks in advance!

That Arduino sketch would have been connecting to Blynk using the ESP8266 in AT mode. This means that the standard ‘factory’ firmware on the ESP was responding to AT commands from the Arduino, sent via the Blynk ‘simple shield’ library.

By uploading a sketch to the ESP8266 you have overwritten this factory AT firmware, so the Arduino sketch no longer has a way to communicate with the Blynk server.

If you want to make this work then you’ll need to come-up with a way of allowing the ESP and the Arduino to communicate with each other using your own communication protocol - maybe using serial or I2C.

Personally, I don’t like these boards, they are the worst of both worlds, but I think a bit of clever marketing has allowed them to appeal to buyers.
You’d be better using a NodeMCU, or just the ESP part of the board you have (which makes it a rather expensive board considering that a NodeMCU costs just a couple of dollars).

Pete.

1 Like

@PeteKnight I understand, and I’d love to get a new one, but I was trying to get my project done for the end of the high school year, as it is my last one. I have spent weeks trying and trying, before actually going out on a forum like this and seeking help. I have probably 10 more days to finish the project or else I will be unable to pass my year, even though my marks are all fine, the project is essential. The board I got apparently is not the best, but I have waited for it around 2 months to arrive and that’s why I am a bit late with my work. Yes, it’s my fault.

I really do not like to ask for this kind of help, but it’s all confusing and stressing for me at this time and I’d like to ask if you could help me with the search or better understanding of how I can do it on alternative ways you mentioned. I already googled, but I couldn’t seem to find what I need.

Thanks in advance!

Understand you urgent situation and your willing to research and fix, I just like to add some steps you have to do

  1. To restore the AT firmware for ESP8266
  • Download at ESP8266 AT Bin V1.54
  • Use esptool.py (for Ubuntu) or esp8266_flasher.exe for Windows to restore AT firmware to ESP8266. Remember to turn SWs 5,6,7 ON (you already know).
  1. Power OFF, turn SW 7 OFF, then Power ON again. Connect to USB and use terminal to verify ESP8266 can accept AT command by inputting AT =>receiving OK

  2. If OK, just turn every SW OFF, only 3+4 ON to upload sketch to UNO using this ESP8266_Shield sketch to verify communications between UNO - ESP8266 - Blynk are all OK.

Remember to change the speed and pins for UNO

// or Software Serial on Uno, Nano...
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(2, 3); // RX, TX

// Your ESP8266 baud rate:
#define ESP8266_BAUD 115200
  1. Turn SW 1,2,3,4 every time after uploading the new sketch to test.

  2. If everything is OK, remember @PeteKnight advice to not use that combination ever (UNO/Nano/Mega + ESP8266 AT).

2 Likes

Thanks for the reply, I’ve tried uploading it, but the Flasher gives me this error: https://prnt.sc/sql76m
I have made sure 5, 6 and 7 switches are on. I even tried with different flasher, he says “FINISH”, prob meaning “FINISHED”, but it seems like it did not upload.

EDIT:
I have succeeded in uploading the firmware, and AT command now returns OK as you have said. I will try to establish a serial connection now and let you know what I have done. Thanks again!

@PeteKnight @khoih

I have successfully flashed AT firmware to the ESP8266 of my Arduino, I have succesfully estabilished connection with Blynk - ESP - Arduino and I’m here to express my huge thanks to both of you for spending your time to help me figure this out!

2 Likes

Congrats. With your attitude, persistence, problem solving and research skills, I believe you will go very far in the future.

2 Likes