BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Email address in "Contact the author" ignores the "+" sign

android
#1

I’m running a local server on a Banana Pi and running my project on an ESP32.
Everything works fine on my primary device (Android Oreo) but when I tried to share the project with another device (Android Oreo), it gave me an error message saying my project app is no longer available (still looking into this issue) and gave me the option to contact the author.

The issue is that when I click on the contact the author button, it initiates an email to my primary address but it replaced the “+” sign with a space. I’m using gmail and added a “+tag” to it.

Didn’t try this on a regular server to check whether is it affected as well or not.

Running the latest versions of the apps and server.

Update: after running more tests, it appears that both issues are related to each other. (the “+” sign prevented the project from being shared probably because it was converted into a spacebar and caused it not finding that email address)

0 Likes

#2

when you are sharing it with the other person, are you sharing it on the Login Screen and scanning the qr code?

0 Likes

#3

or already logged in to the private server and hitting the qr scan button?

0 Likes

#4

Yes, the secondary device is reading the qr code from the login screen.

Here is what I did:
On the primary device, I stopped the project and generated the QR code
On the secondary device, I scanned the qr code from the login screen (I expected it to fail at this stage as the project isn’t running yet on the primary device)
Back to the primary device, I started the project and made sure it’s working fine and the was ablr to control the device connected to the ESP
Back to the secondary device, I clicked on try again. I expected it to work this time as the main project is running on the primary account now but it didn’t

Thanks

0 Likes

#5

I need to control the same HW, to my understanding, I have to share the access from the login the screen to do so. Doing it after logging into a different account would clone the project but provides a different auth key.

Last time I used Blynk was last year or so and the share feature did work at that time (unless if I logged in using the same account on both devices)

0 Likes

#6

On this screen (on the secondary device) are your local server details correct?

Pete.

0 Likes

#7

I get the same thing when i pull up NoX. … private server, same basic setup (except im ios on orig).

Tells me to contact the author. Investigating…

0 Likes

#8

i even tried your suggestion pete, and then even created a new account on my server to make sure i was connected.

0 Likes

#9

by the way Blyker, instead of a plus sign, try \+ or email;email (semi colon) . or try to htmlify the email address.

0 Likes

#10

Yes, tried with options to no avail

0 Likes

#11

im pulling up https://server/auth/qr right now to test that one out…on my new created account.

0 Likes

#12

Ok, will try the +. Lost my login credentials, so will need to start over again

Reda

0 Likes

#13

Just tested the share function using the Blynk server and same issue happened

0 Likes

#14

i got it to work. but i dont know how.

i think i had to create an account so it left the default server filled in, in the section Pete highlighted above. I logged out and then imported my project. it told me the project was stopped on the other device, i started it up and it started working.

0 Likes

#15

It turned out both issues are related, the app probably reads the email as a url code and converts the “+” into a spacebar. I was able to share the project once I removed the “+” sign from the email.

Thanks for your help @lvennard

1 Like