Disconnection Problems with Wemos Board

Hi All, Not sure we like resurrecting topics, but I have a very similar problem but I’m not using Pin 6 and this is a Wemos D1 knockoff. This thread seemed the most appropriate after I checked them all.
I got it as far as compiling and connecting, but then it disconnects and tries again forever. I’ve tried all settings and looked at all of Google. I need your help!

The Serial Monitor looks like this (in a loop): - code is below.

564] Connected to WiFi
00:20:43.107 -> [564] IP:
00:20:43.107 -> [564] 
00:20:43.107 ->     ___  __          __
00:20:43.144 ->    / _ )/ /_ _____  / /__
00:20:43.177 ->   / _  / / // / _ \/  '_/
00:20:43.210 ->  /____/_/\_, /_//_/_/\_\
00:20:43.210 ->         /___/ v0.6.1 on ESP8266

00:20:43.277 -> [634] Connecting to blynk-cloud.com:80
[1347] Ready (ping: 101ms).
H!⸮⸮!⸮D⸮N[60] Connecting to SpeedTrap
[564] Connected to WiFi
00:20:51.544 -> [564] IP:
00:20:51.578 -> [564] 
00:20:51.578 ->     ___  __          __
00:20:51.612 ->    / _ )/ /_ _____  / /__
00:20:51.646 ->   / _  / / // / _ \/  '_/
00:20:51.682 ->  /____/_/\_, /_//_/_/\_\
00:20:51.682 ->         /___/ v0.6.1 on ESP8266

00:20:51.753 -> [634] Connecting to blynk-cloud.com:80
[978] Ready (ping: 94ms).
?)⸮⸮⸮d⸮DH⸮[62] Connecting to SpeedTrap
[566] Connected to WiFi

…you get the picture.

Here’s the code, Frankenstein-monstered from this whole forum, Blynk examples, etc:

#define BLYNK_PRINT Serial
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>
#include <Servo.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[40] = "XXXXXXXXX";
char ssid[15] = "XXXXXXXXXX";
char pass[20] = "XXXXXXXXXX";

Servo servoRAIN7;
Servo servoWIND9;
Servo servoSUN8;




void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);

  servoRAIN7.attach(7);  // Set left servo to digital pin 10
  servoWIND9.attach(9);  // Set right servo to digital pin 9
  servoSUN8.attach(8);  // Set right servo to digital pin 8
void loop()


but should you use pin 9?

1 Like

The pin numbers that you’re using here are GPIO numbers, They aren’t the same as the D numbers printed next to the pins on your Wemos D1 Mini.

If you take a look at this:

You’ll see that it says that GPIO 6-11 are reserved, and shouldn’t be used (there are no pins connected to them anyway).

Edited to add…
I’ve just re-read this and I’m now not clear what type of board you’re using. You tagged your post onto a thread about a NodeMCU board, and you’ve said that you’re using a Wemos D1. If that’s a D1 Mini then what IO’ve said above is correct.
If it’s one of those Arduino sized boards known as a D1 R1 then none of my comments are relevant.

Either way, I’ve split this to its own topic, as I’m not sure that the two issues are related.


Thanks, Pete.
Here’s what I’m using - it was labelled as an Arduino Wifi ‘Shield’, but it’s clearly not - trying to make it work anyway

Okay, so turn the board over and where it says GPIO5, GPIO4 etc, those are the numbers that need to go in your code here:

servoRAIN7.attach(7); // Set left servo to digital pin --
servoWIND9.attach(9); // Set right servo to digital pin 9
servoSUN8.attach(8); // Set right servo to digital pin 8

instead of the numbers you are currently using.


Not sure if it’s customary to say ‘thank you’ here, but it is with me, @PeteKnight
[SOLVED] with updated pin numbers!

1 Like

“Thank You’s” not necessary, but always appreciated :smiley:
It’s also nice to know that the problem was fixed, and it’s useful info for anyone who does a search in future.