Didn't find Let's Encrypt certificates

Hi guys

First off all , sorry for my english :wink:

I’ve been trying to get the Blynk server to work on a raspberry zero for several days, it works but I can’t get it to work with the letsencrypt certificate.
I have tried in the path of /etc/letsencrypt/live/xxxxxx.duckdns.org / … I have moved the files to the Blynk directory, I have tried with ports 80 and 443 of the router open but nothing, I changed chmod of files…

Now, when I open Blynk server , my log file said:

17:02:44.900 INFO - Didn’t find Let’s Encrypt certificates.
17:02:44.903 INFO - Automatic certificate generation is turned ON.
17:02:48.299 INFO - HTTP API and WebSockets server listening at 8080 port.
17:02:48.321 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
17:02:48.331 INFO - Mqtt hardware server listening at 8440 port.

I can’t find anything current in google to fix the problem


and now, I have this:

pi@blynk:~ $ sudo java -jar /home/pi/Blynk/server-0.41.16-java8.jar -dataFolder /home/pi/Blynk -serverConfig /home/pi/Blynk/server.properties
Exception in thread “main” java.lang.RuntimeException: File does not contain valid private key: /etc/letsencrypt/live/xxxxxxxxxx.duckdns.org/privkey.pem
at cc.blynk.server.SslContextHolder.initSslContext(SslContextHolder.java:139)
at cc.blynk.server.SslContextHolder.(SslContextHolder.java:86)
at cc.blynk.server.Holder.(Holder.java:156)
at cc.blynk.server.launcher.ServerLauncher.start(ServerLauncher.java:96)
at cc.blynk.server.launcher.ServerLauncher.main(ServerLauncher.java:73)

I check lets with apache server and word it correctly

And if I used y server.properties


y recived this:
Blynk Server successfully started.
All server output is stored in folder ‘/home/pi/logs’ file.
Generating own initial certificates…
Error during certificate generation.
Challenge failed… Giving up.