Device is disconnected (but not really)

Merry Christmas to everyone.

I have started a Private Blynk Server and try to manipulate it to my needs.
I succeeded to start it and create new users with android app.
I also succeeded to upload the basic sketch for a nodemcu esp8266 and created a button to power on off the GPIO16 onboard led.
The server always states the correct condition of the hardware device (actually i turned the logging to trace and view all the succesfull pings).
On the android app the device is showing most of the time offline. When i reboot the hardware device it turns for a moment to online and then in millis get the message “Device is disconnected” and turns to offline.
Though it seems to be offline device responds correctly to turning the led on and off so i guess this is a bug of the Blynk android app.
When i restart the server then the app works properly until rebooting of the hardware.
You understand the rebooting the server in not a good solution though i created a basic script for doing it.

I am using the latest Blynk Server (0.21) and tested the 0.21.1.SNAPHOT and the latest Blynk android app which in the bug fixes says that the device offline problem was corrected. I haven’t tried any previous version so i don’t know.

Thank you

PS - ESP ino

cpp
#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "XXXXXXXXXXXXXXXXXXXXXXX";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "XXXXXXXXXXX";
char pass[] = "XXXXXXXXXXXXX";


void setup()
{
  Serial.begin(9600);
  Blynk.begin(auth, ssid, pass, IPAddress(XXXXXXXXXXXXXX));
  
}

void loop()
{
  Blynk.run();
  
}

Yeah, same issue here.
Device shown as offline but working as expected. After restart of the esp it is shown online for a short while.Two other devices in my project are shown correctly. Also using latest android app and 0.21.0 server.

Hi Andre,

what kind the other two devices are?
Do you believe that it has to do with the ESP8266?

@gkal hello. Please try download https://github.com/blynkkk/blynk-server/releases/download/v0.21.0/server-0.21.1-SNAPSHOT.jar again. This issue was fixed just few days ago. Please let me know if that helps.

Hello Dmitriy.
I have tested yesterday with 0.21.1. Snapshot but the problem persists.

I updated build just now. Previous was without fix.

Thank you very much.

I will try later and reply.

Merry Christmas

2 Likes

It seem that the glitch has been fixed with Snapshot 0.21.1.

Thank you again Dmitriy

It seems that the problem reappeared with server 0.21.2 so i reverted to 0.21.1

Can you please check this out.

Thank you and a really happy wonderful Blynk year :evergreen_tree:

In 0.21.2 were no changes related to status, so this is very unlikely. I’ll check anyway.

@gkal could you please check this build?

Hi Dmitriy.

The problem is solved in 0.21.3-SNAPSHOT.
0.21.3.jar is working flawlessly also. :relaxed:

Thank you very much.