Deterioration of sketch upload capability – now complete failure of run

Alright, I had scotches working, for the last couple months, using:

  • Nano 33 IoT
  • WiFi connection via hotspot on iPhone (either cellular or WiFi)
  • Blynk server

Now I cannot upload other sketches and the device is not connecting to the Blynk server.

If I go to bootloader and upload blank sketch, then I can recover my upload capability, until I put a Blynk sketch using WiFi back on the device, then I loose capability to upload and an LED indicator I have built in which indicates the sketch is running no longer functions, and when I open Blynk app and try to run the program, I get ‘offline’ message.

The WiFi connection is in place according to the iPhone. The codes/pswd are correct.

I have tried this with two Nano 33 IoT device, one that has never been on the Blynk cloud before, and both have the same failure/recovery. As far as I can tell, everything is the most current version.

Like I started with, the sketch was working but the upload and performance capability has continued to deteriorate and is now in complete failure…and non-Blynk sketches work after the reset.

Ideas of what is happening, how it can be resolved, reading that will bring me to a resolution…
Is there a ‘reset’ button?

Thanks, Sean

I dont have any answers, just troubleshooting steps.

  1. what happens if you only try a bare bones sketch for wifi on the nano33 ? does it work ?

  2. blynk server… im guessing that means blynk cloud and not a local blynk server ?

you could always post the code that works, and the code that doesnt so folks could compare.

Thanks @lvennard

  1. bare bones (one vPin and one LED) has same issue
    1-a) tried iPhone hotspot and home WiFi - same issue
  2. yes “cloud” (a server somewhere else) and not “local server”

As indicated, this is not a code issue as the issue developed gradually and code that worked previously no longer works; basically, I cannot connect to Blynk “cloud” at all:

My code and a bare bones sketch/app on either my iPhone hotspot or my home WiFi yield the Blynk hash graphic for connection

22:10:22.351 -> [13595] Connecting to ***iPhone
22:10:25.132 -> [16411] IP: ***
22:10:25.132 -> [16412] 
22:10:25.132 ->     ___  __          __
22:10:25.132 ->    / _ )/ /_ _____  / /__
22:10:25.132 ->   / _  / / // / _ \/  '_/
22:10:25.132 ->  /____/_/\_, /_//_/_/\_\
22:10:25.132 ->         /___/ v1.0.0-beta.1 on Arduino
22:10:25.132 -> 

and then this until timeout:

22:10:25.132 -> [16414] Connecting to
22:10:29.376 -> [20618] Invalid auth token
22:10:43.152 -> [34413] Connecting to
22:10:43.812 -> [35059] Invalid auth token

I have checked/refreshed the tokens (three in total now) and they match in my code and in the Blynk app but same outcome.


A thought, I removed the synch events as my code was working and did not need to report a previous condition - did I create a backlog of issues that is blocking connection? am on on a secret blacklist? is Mercury misaligned with Jupiter?

upgrade to v1.0.0-beta.3 and you should be set. the admins just posted a few hours ago there was the new testing server in that beta.1 library.

Thanks, solved the token issue but, evidently, I had two problems - once a sketch is loaded that is calling on the Blynk cloud server, I cannot load a new sketch without wiping via bootloader … less anointing than abject failure.

any error messages we could see?