Datastream invalidate

Hola, con la invalidación de las datastreams, por tiempo, por ejemplo que ponga en default valor una datastream después de 15 minutos, esto no tiene efectos sobre el dispositivo, si sobre las dashboards pero no sobre el device. El device nunca se entera.

The assumption is that the device has stopped communication with Blynk, so sending any data back to the device is impossible.

The data invalidation functionality is to make it clear to the user that data is no longer being sent to the server/device, rather tan the device just showing the last value that was received and the user assuming that it’s an up-to-date value.

Pete.

1 Like

If you would like to make a time based actions, for example turning a switch on or off after 15 minutes, you can try automation
https://docs.blynk.io/en/blynk.apps/automations

Thanks for all replies. The case is that im not use the invalidation functionality on data from the device otherwise to device. My intention is make a timer auto power off switch, but the automation functionality do not have a timer trigger option, or i don look this.

I do not find how to add the automation opción to my button in app, mine app. In mine app, i have a switch and the idea is that 15 minutes after the button was turn on, then turn off automatically it self.

That’s not right

Yes, thanks, i was see that, but this is an action, not a trigger. How can i do to make to run this action if can not set a trigger?.

This is an example

When i read the data that jhon93 shared with me, i thing “ok, i need wait action with manual scene combined”, but then i not find how the automations option are integrated to mine app, i is mean that automation funtionality works independient way

You don’t add it to they button, you add it to the datastream that the button is attached to.

Have you done this part in the datastream Advanced Settings…

https://docs.blynk.io/en/blynk.console/templates/datastreams/datastreams-common-settings/automation

Pete.

1 Like

Ahh, ok. Thanks you very much, i will try thats now.

Where go the automations menus?..

When you create a datastream go to advanced settings and turn on expose to automation and check both available in actions and available in conditions.


Ok, reappear it…

It’s working. Thank you for the patient and the knowledge, you are great.

1 Like