Connecting to ESP8266 from an external network

Hi Guys,

I would like apologize if this has already been answered, but i did search and didn’t find a suitable answer :slight_smile:

I have an ESP8266 Huzzah board with Blynk library version 0.3.7 running the example sketch Push Notification. I have an LED connected to GPIO 5 and a push button on GPIO 2. I have the ESP connected to the Blynk cloud server. I am also using the latest version of the Android APP.

The following works great when my phone is connected to the same WIFI network as the ESP.

  • Receive push notification when the push button is pressed.
  • I can turn the LED on.

When I am NOT connected to the same WIFI network, so for example I am connected to my cell phone providers network I can receive the Push notification when push button is pressed, this works great. But when I try open the dashboard or try and control the ESP using the APP I get the error message “ESP8266 is not on the network”.

I am assuming the ESP can connect to the internet because I am receiving the Push notification’s I just cant control it.

Any advice would be appreciated.

Thanks guys.

I can’t help you with technical troubleshooting on this, but as a step: Are you able to move your ESP device to a different wifi network and test again with your phone on the cell network?

Did you change anything in app? Maybe some settings?

Thanks for the replies.

@structure7 I have not managed to test this on another network, I will try that tomorrow.

@Dmitriy The only change I made to the sample code was to include the <ESP8266WiFi.h> and <BlynkSimpleEsp8266.h> libraries into the example.

Since then I tried the ESP8266_Standalone example with no changes at all, this gives me the same result. Works great when I am on the LAN over another network no joy.

Do you think there is a port forwarding issue on my side?

Thank you,

Could you please ping blynk-cloud.com from your cell network and do the same from home network. What are results?

I get a reply from my home network and my cell network. However the DNS seems to resolve to a different IP.

Home network resolves blynk-cloud.com to 46.101.143.225

Cell network resolves blynk-cloud.com to 45.55.130.102

I will try look for a way to manually configure the DNS address on the ESP, I suspect that will “resolve” :wink: my problem.

AS temporary solution you may hardcode IP in app to those one server you see in home network untill we will fix issue. Or you couold install local server.


Brilliant. Thanks for the great support, and keep up the great work you guys are doing with Blynk…

1 Like